Как из файла excel в сделать макет для 1с?

Бухгалтера работают с большими массивами данных. Нередко нужно загрузить в 1С из Excel данные таблиц, справочников, прайс-листов, списков. В 1С есть механизм переноса данных из электронных таблиц в программу. Специальная обработка позволяет быстро загрузить нужные показатели в 1С 8.3 из Excel.

В программах 1С на платформе 8.3 встроен механизм закачки данных из электронных таблиц. Данные можно загрузить в справочники «Контрагенты» и «Номенклатура».

В программах на платформе 8.2 нет встроенного механизма закачки в 1С из Эксель, но есть специальная внешняя обработка. С ее помощью можно закачать данные из таблиц в справочники и документы.

В этой статье читайте инструкцию про загрузку данных из Excel в 1С для обеих платформ.

Быстрый перенос бухгалтерии в БухСофт

Откройте обработку для загрузки данных в 1С 8.2

Внешняя обработка «ЗагрузкаДанныхИзТабличногоДокумента» позволяет загрузить данные из табличного документа в 1С 8.2 Бухгалтерия. Эту обработку можно скачать здесь. Чтобы начать работу с обработкой надо открыть ее в программе. Для этого зайдите в раздел «Файл» (1) и нажмите ссылку «Открыть» (2). Откроется окно для выбора файла.

Как из файла excel в сделать макет для 1с?

В окне выберете скачанный файл «ЗагрузкаДанныхИзТабличногоДокумента» (3) и нажмите кнопку «Открыть» (4). Откроется окно обработки.

Как из файла excel в сделать макет для 1с?

В открывшемся окне вы видите поле «Режим загрузки» (5). Под ним есть поле (6), в котором будут разные данные в зависимости от того, какое значение вы выберете в поле (5).

В поле «Режим загрузки» надо выбрать одно из трех значений:

  1. Загрузка в справочник. Выбираете в случае, если надо закачать данные из Excel в какой-либо справочник 1С: «Номенклатура», «Контрагенты», «Физические лица», «Статьи затрат» и т.д. При выборе этого значения поле (6) будет называться «Вид справочника»;
  2. Загрузка в табличную часть. Выбираете в случае, если надо закачать данные из таблицы в какой-либо документ: реализацию товаров, поступление товаров, возврат товаров и так далее. При выборе этого значения поле (6) будет называться «Ссылка»;
  3. Загрузка в регистр сведений. Выбираете в случаях, когда хотите закачать данные из таблицы в специальные регистры. При выборе этого значения поле (6) будет называться «Вид регистра».

Как из файла excel в сделать макет для 1с?

В следующей главе подробно расскажем как происходит в закачка из excel справочника номенклатуры.

Гость, для Вас открыт бесплатный доступ к чату с бухгалтером-экспертом

Закажите обратный звонок на подключение или позвоните: 8 (800) 222-18-27 (бесплатно по РФ).

Загрузите в 1С 8.2 данные в справочник номенклатуры

Если у вас есть прайс-лист или спецификация от поставщика с большим объемом данных в формате Эксель, то вы можете загрузить эти данные в бухгалтерскую программу в справочник номенклатуры. Например, у вас есть такой прайс-лист в табличном формате формате:

Как из файла excel в сделать макет для 1с?

Если у вас будет поставка этого товара, то вам надо создать новую номенклатуру в справочнике. Воспользуйтесь для этого обработкой «ЗагрузкаДанных…». Откройте эту обработку как написано в предыдущей главе и выберете в поле «Режим загрузки» значение «Загрузка в справочник» (1). В поле «Вид справочника» выберете «Номенклатура» (2).

В табличной части, во вкладке «Табличный документ» (3) вы увидите таблицу с полями «Код», «Наименование» и т.д. В этой таблице много полей, но нам нужны только «Артикул», «Наименование» и «Полное наименование», другие данные мы загружать не будем. Чтобы оставить только нужные поля зайдите во вкладку «Настройка» (4). Откроется окно настройки полей.

Как из файла excel в сделать макет для 1с?

В окне настроек в левом столбце оставьте галочки только напротив полей:

  • «Наименование» (5);
  • «Артикул» (6);
  • «Полное наименование» (7);
  • «Базовая единица измерения» (8).

Если вы хотите, чтобы новая номенклатура загрузилась в конкретную папку в справочнике «Номенклатура», то также поставьте галочку напротив поля «Родитель» (9). В этом поле надо будет указать название папки. После настройки полей снова перейдите во вкладку «Табличный документ» (10).Как из файла excel в сделать макет для 1с?

Во вкладке «Табличный документ» нажмите кнопку «Обновить» (11). Теперь в табличной части остались только нужные поля.

Скопируйте данные из Excel и вставьте их в соответствующие поля во вкладке «Табличный документ».

В поле «Базовая единица измерения» (12) укажите «шт». В поле «Родитель» (13) укажите папку справочника «Номенклатура», в которую хотите добавить новые позиции. В нашем примере это папка «Офисная мебель». Верхняя строка таблицы содержит названия полей, не удаляйте ее.

После того, как вы вставили данные в табличный документ, нажмите кнопку «Загрузить» (14). После этого появится сообщение о подтверждение загрузки, нажмите «Да». Теперь номенклатура загружена из Excel в папку.

Как из файла excel в сделать макет для 1с?

После успешной загрузки появится служебное сообщение о том, сколько элементов загружено в справочник (15).

Как из файла excel в сделать макет для 1с?

Зайдите в соответствующий справочник и убедитесь, что данные (16) загружены.

Как из файла excel в сделать макет для 1с?

Аналогичным способом можно закачать из Эксель в 1С данные и в другие справочники и документы.

Загрузите в 1С 8.3 номенклатуру из электронной таблицы

В программах на платформе 1С 8.3 есть встроенный механизм загрузки. Он позволяет сделать закачку в 1С из Эксель в справочники «Номенклатура» и «Контрагенты». Чтобы загрузить номенклатуру из Excel в 1С 8.3 Бухгалтерия зайдите в раздел «Справочники» (1) и кликните на ссылку «Номенклатура» (2). Откроется справочник номенклатуры.

  • Допустим, нам надо загрузить номенклатуру из предыдущего примера:

В справочнике номенклатуры зайдите в папку, в которую надо загрузить новую номенклатуру (3) и нажмите кнопку «Загрузить» (4). Откроется окно для выбора файла загрузки.

  1. В окне выбора укажите на загружаемый файл (5) и нажмите кнопку «Open» (6).

Откроется окно «Шаг 1. Подготовка данных к загрузке». В нем надо удалить лишние поля и указать в названиях полей правильные реквизиты. В нашем примере удалите поле со сквозной нумерацией (6), его загружать не надо. Для этого встаньте мышкой на любую ячейку в этом поле и нажмите кнопку «Удалить колонку» (7). Поле будет удалено.

Далее нажмите на ссылку «Укажите реквизит» (8). Такое название поля и его красный цвет говорят о том, что 1С не определил, к какому реквизиту справочника относятся данные в поле.

Названия полей, указанные синим цветом, 1С определил автоматически. После нажатия откроется окно «Укажите реквизит» (9). В нем кликните на нужный реквизит (10) и нажмите кнопку «ОК» (11).

Название поле поменяется на указанное.

Теперь осталось удалить лишние строки. В нашем примере это строка с названиями полей (12), которые выгрузились из файла. Эта строка находится под названиями полей, выделенных синим цветом (13). Встаньте на удаляемую строку и нажмите кнопку «Удалить строку» (14). Строка удалится.

Теперь данные готовы к загрузке. Нажмите кнопку «Далее» (15) для завершения загрузки. Откроется окно «Загрузка номенклатуры из файла».

В открывшемся окне во вкладке «Новые» (16) виден реестр новой номенклатуры, которая будет загружена в справочник номенклатуры 1С.

Выберете в поле «Тип цен» (17) любое значение из справочника, например «Розничная».  Нажмите на ссылку «Реквизиты новой номенклатуры…» (18). Откроется окно для указания дополнительных реквизитов:

  • В поле «Входит в группу» (19) укажите папку в справочнике номенклатуры, куда должны войти новые товары;
  • В поле «Номенклатурная группа» (20) укажите нужную номенклатурную группу
  • В поле «Единица» (21) выберете единицу измерения для новых товаров

Для сохранения реквизитов нажмите «ОК» (22). Для загрузки новых товаров нажмите кнопку «Загрузить» (23). Новые товарные позиции появятся в папке в справочнике номенклатуры.

  • Теперь в справочнике номенклатуры в папке «Офисная мебель» мы видим новые товарные позиции, загруженные из таблицы Excel:

Загрузите в 1С 8.3 контрагентов из Excel

Как загрузить в 1С 8.3 данные из файла excel? Чтобы загрузить контрагентов из Эксель в 1С Бухгалтерия 8.3 зайдите в раздел «Справочники» (1) и кликните на ссылку «Контрагенты» (2). Откроется справочник контрагентов.

В справочнике нажмите кнопку «Загрузить» (3), выберете файл с данными по контрагентам и загрузите его. В дальнейшем действуйте по инструкции из предыдущей главы.

Источник: https://www.BuhSoft.ru/article/1678-zagruzka-v-1s-iz-excel-v1

Загрузка из Excel в 1С 8.3

В работе с конфигурациями 1С имеется возможность загружать данные из файла Excel. Пожалуй, самый распространенный вариант — это загрузка Номенклатуры в справочник из прайса.

 Этот вопрос актуален для пользователей конфигураций Управление торговлей, Бухгалтерия предприятия, Розница и т.п., которым в работе приходится сталкиваться с большими объемами информации.

 В программах имеется встроенный механизм загрузки файлов формата Excel.

Рассмотрим на примере программы 1С: Бухгалтерия 3.0 загрузку данных из документа. Скачаем любой прайс в формате Excel документа и загрузим его в справочник Номенклатура.

Как загрузить номенклатуру в 1C 8.3 из файла Excel

Как из файла excel в сделать макет для 1с?

Откроем справочник Номенклатура (пункт меню Справочники — Номенклатура), создадим группу номенклатуры, куда будем загружать новый прайс (кнопка Создать группу). В нашем примере назовем ее — Запчасти Тайга. Для загрузки номенклатуры из прайса нажимаем кнопку Загрузить и выбираем файл Excel.

Как из файла excel в сделать макет для 1с?

В таблицу обработки Загрузка номенклатуры из файла будут перенесены все данные из документа Excel. Нажав кнопку Убрать все лишнее программа 1С автоматически убирает ненужные строки. Если останется лишняя строка (или колонка) ее можно убрать, нажав кнопку — Удалить строку (Удалить колонку).

Читайте также:  Как из windjview сделать word?

Как из файла excel в сделать макет для 1с?

Далее, в шапке нашей таблицы, нажав ссылку Укажите реквизит, необходимо задать соответствие каждой колонке. В нашем примере это Артикул, Наименование и Цена.

Как из файла excel в сделать макет для 1с?

В результате у нас получается такая таблица. Нажимаем кнопку Далее.

Как из файла excel в сделать макет для 1с?

В следующей таблице видим весь список номенклатуры и установленный тип цен. Здесь можем задать дату, на которую будет установлена цена. Элементы у нас все помечены знаком плюс (+), т. е. при загрузке будет создаваться новый элемент номенклатуры.

В случае нахождения наименования номенклатуры в базе, она будет показана на закладке Все без знака «+» и повторно создаваться не будет. PDF

Как из файла excel в сделать макет для 1с?

Нажав на ссылку Реквизиты новой номенклатуры, укажем необходимые параметры. В нашем примере укажем, что все загружаемые элементы принадлежат группе номенклатуры Запчасти Тайга. Нажимаем ОК и Загрузить.

  • Как из файла excel в сделать макет для 1с?
  • Проверяем справочник — номенклатура загружена.
  • Как из файла excel в сделать макет для 1с?

Загрузка в 1С документов поставщика в формате Excel

В программах 1С также реализована возможность загрузки документов поставщика в формате Excel. Загрузка возможна используя документы ТОРГ-12, Акт приема-сдачи работ (услуг) или УПП полученные от поставщика в формате Excel. Так, если поставщик сохранит и отправит нам документы в формате Excel, мы без труда сможем загрузить их себе в программу 1С.

Также, если необходимо отправить покупателю документ для загрузки покупателем себе в программу, то нам тоже необходимо его сохранить. Сделать это можно из печатной формы документа.

Рассмотрим, на примере программы 1С: Бухгалтерия предприятия 3.0. Создадим документ Реализация (акт, накладная) и нажав кнопку Сохранить, выберем формат Лист Microsoft Excel.

Как из файла excel в сделать макет для 1с?

Получив такой документ от поставщика загрузим его себе. Для этого перейдем в журнал документов Поступление (акты, накладные) в разделе меню Покупки и воспользуемся кнопкой Загрузить. Выбираем вариант загрузки Из файла.

  1. Выбираем файл, полученный от поставщика.
  2. В том случае, если загрузка производится впервые, то программа 1С предложит сопоставить номенклатуру поставщика с имеющийся у вас номенклатурой.
  3. Сопоставив все элементы, нажимаем кнопку Записать и закрыть.

Если сопоставление справочников производилось ранее, то программа 1С 8.3 автоматически загрузит сразу все данные в документ.

  • Остается только проверить правильность документа и провести его.
  • Таким образом, загрузка в программу 1С данных используя табличные документы Excel повышает эффективность работы в программе, снижает риск возникновения ошибок, тем самым облегчая работу пользователей.
  1. См. также:
  2. Если Вы еще не являетесь подписчиком системы БухЭксперт8:
  3. Активировать демо-доступ бесплатно →
  4. или
  5. Оформить подписку на Рубрикатор →
  6. После оформления подписки вам станут доступны все материалы по 1С Бухгалтерия, записи поддерживающих эфиров и вы сможете задавать любые вопросы по 1С.

Помогла статья?

Получите еще секретный бонус и полный доступ к справочной системе БухЭксперт8 на 14 дней бесплатно

Источник: https://BuhExpert8.ru/obuchenie-1s/administrirovanie-1s/zagruzka-iz-excel-v-1s-8-3.html

Загрузка в 1С 8.3 из Excel или табличного документа

В 1С 8.3 есть возможность массово загрузить список номенклатуры из табличного документа, например, из файла Excel.

Для загрузки мы используем внешнюю обработку ЗагрузкаДанныхИзТабличногоДокумента.epf для управляемых форм (8.2 и 8.3), которую можно скачать отсюда. Она универсальна и должна подходить для любой конфигурации, написанной под управляемое приложение.

  • Если Вы программист и хотите разработать «свою» загрузку из Excel, подробная инструкция по ссылке;
  • Пример загрузки прайс-листа в 1С Управление торговлей можно найти по ссылке.

Чтобы запустить внешнюю обработку, нужно зайти в меню «Файл», далее «Открыть» и выбрать эту обработку из каталога, в котором она была сохранена:

Как из файла excel в сделать макет для 1с?

Обработка Загрузка данных из табличного документа 1С 8.3 (управляемые формы)

После того как обработка открылась в 1С, можно приступать к работе с ней. В первую очередь нам нужно определиться, куда и что мы будем загружать:

Как из файла excel в сделать макет для 1с?

Я хочу привести пример на справочнике «Номенклатура«. Я создал некий файл с данными в формате xls.

Обращу внимание, что файл нужно сохранить в формате «Книга Excel 97 – 2003, то есть расширение должно быть именно xls (если мы загружаем из Excel-я). Другие обработка не видит.

Обработка умеет загружать также файлы формата:

  • mxl,
  • xls,
  • txt,
  • dbf,
  • любой другой формат, откуда можно скопировать данные.
  • Вот так выглядит файл Excel с исходными данными, который мы будем загружать в справочник «Номенклатура»:
  • Как из файла excel в сделать макет для 1с?
  • Получите 267 видеоуроков по 1С бесплатно:

Я не стал прописывать все поля справочника, так как этого достаточно для понимания принципа загрузки. Кроме того, этих данных хватает для начала работы с данными позициями.

Данных позиций пока нет в информационной базе 1С, и мы сейчас туда их загрузим.

Нажимаем на значок «Открыть» (на рисунке обозначен как «Выбор источника») и выбираем файл с данными. Можно использовать простое копирование информации. Мой файл с примером можно скачать здесь. Данные загрузятся в обработку автоматически. Теперь проверим, правильно ли мы заполнили наши данные. Для этого нажимаем кнопку «Контроль заполнения».

Как из файла excel в сделать макет для 1с?

Как видно, у нас появились ошибки! Будем устранять. Заходим на закладку «Настройка»:

Как из файла excel в сделать макет для 1с?

Прежде чем исправлять ошибки, хочу обратить внимание на одну важную деталь. Программа изначально не знает, по какому полю ей искать элемент справочника на случай, если он там уже есть. Поэтому ей нужно его указать.

Я предпочитаю искать по коду, так как он, как правило, уникален. В колонке «Поле поиска» в строке «Код» ставим галочку. Теперь, если запись с таким кодом будет найдена, она будет заменена, в другом случае — создана.

Важно! Если не указать поле поиска, то могут появиться дубли номенклатуры. Особенно после второй загрузки похожего файла!

Теперь посмотрим, почему ругается на поле «Единица». Дело в том, что единицы измерения в 1С 8.3 хранятся в отдельном справочнике, и обработка по умолчанию ищет эту единицу по наименованию. А на самом деле словом единица прописана в поле «Полное наименование».

К сожалению, обработка может вести поиск только по «Наименованию» и «Коду» (для программиста возможности шире). Если обратите внимание на рисунки выше, то увидите, что в колонке «Единица» у меня стоит код. И в обработке нужно указать, что поиск нужно вести по коду. Щелкаем два раза по колонке «Условие связи» напротив «Единицы» и меняем на «Код».

Теперь смотрим, что нам что-то там про «Услугу» говорят в списке ошибок. Еще одно важное замечание. Колонки в файле должны располагаться строго в том же порядке, как и строки полей справочника. А у нас «Вид номенклатуры» находится в самом низу, а в файле после колонки «Комментарий».

Для того чтобы поднять строку «Вид номенклатуры» вверх, существуют синие стрелочки вверху формы. С помощью стрелки «Вверх» поднимаем нужную строку и ставим под «Комментарием».

  1. Как из файла excel в сделать макет для 1с?
  2. Жмем «Загрузить данные», и на этот раз все проходит без ошибок:
  3. Как из файла excel в сделать макет для 1с?
  4. Видеоурок по загрузке товаров в 1С из файлов Excel:
  5. Другие статьи по 1С:
  6. Если вы начинаете изучать 1С программирование, рекомендуем наш бесплатный курс (не забудьте подписаться на YouTube — регулярно выходят новые видео):

К сожалению, мы физически не можем проконсультировать бесплатно всех желающих, но наша команда будет рада оказать услуги по внедрению и обслуживанию 1С. Более подробно о наших услугах можно узнать на странице Услуги 1С или просто позвоните по телефону +7 (499) 350 29 00. Мы работаем в Москве и области.

Источник: https://programmist1s.ru/zagruzka-nomenklaturyi-v-1s-8-3-iz-excel-ili-dbf/

Работа с файлами Excel

MS Excel давно стал стандартом для работы с электронными таблицами. В статье рассматриваются способы программной выгрузки и загрузки из 1С в файлы Excel.

Существует несколько способов программной работы с файлами Excel из 1С. Каждый из них имеет свои преимущества и недостатки.

Обмен через табличный документ
Обмен через OLE
Использование COMSafeArray
Обмен через ADO
Выгрузка без программирования

Обмен через табличный документ

Данный способ простой. Его суть заключается в том, что объект ТабличныйДокумент имеет методы:

  • Записать(, ) для выгрузки данных в файл;
  • Прочитать(, ) для загрузки данных из файла.

Внимание!

Метод Записать() доступен как на клиенте, так и на сервере. Метод Прочитать() доступен только на стороне сервера. Необходимо помнить об этом
при планировании клиент-серверного взаимодействия.

Рассмотрим пример сохранения табличного документа в файл. Необходимо любым способом создать и заполнить объект ТабличныйДокумент, а выгрузка в файл осуществляется всего лишь одной строкой:

ТабДок.Записать(ПутьКФайлу, ТипФайлаТабличногоДокумента.XLSX);

Здесь ТабДок — сформированный табличный документ, ПутьКФайлу — имя файла для выгрузки, ТипФайлаТабличногоДокумента.XLSX — формат создаваемого файла. Поддерживаются следующие форматы Excel:

  • XLS95 — формат Excel 95;
  • XLS97 — формат Excel 97;
  • XLSX — формат Excel 2007.

Загрузка из файла осуществляется также достаточно просто:

ТабДок = Новый ТабличныйДокумент;
ТабДок.Прочитать(ПутьКФайлу, СпособЧтенияЗначенийТабличногоДокумента.Значение);

Здесь ПутьКФайлу — путь к загружаемому файлу Excel. СпособЧтенияЗначенийТабличногоДокумента.Значение определяет, каким образом нужно интерпретировать данные, считываемые из исходного документа. Доступны варианты:

Читайте также:  Как сделать лист горизонтально в word 2010?

Обмен через OLE

Обмен через технологию OLE automation, пожалуй, самый распространенный вариант программной работы с файлами Excel. Он позволяет использовать весь функционал, предоставляемый Excel, но отличается медленной скоростью работы по сравнению с другими способами. Для обмена через OLE требуется установка MS Excel:

  • На компьютере конечного пользователя, если обмен происходит на стороне клиента;
  • На компьютере сервера 1С:Предприятие, если обмен происходит на стороне сервера.

Пример выгрузки:

// Создание COM-объекта
Эксель = Новый COMОбъект(«Excel.Application»);
// Отключение вывода предупреждений и вопросов
Эксель.DisplayAlerts = Ложь;
// Создание новой книги
Книга = Эксель.WorkBooks.Add();
// Позиционирование на первом листе
Лист = Книга.Worksheets(1);

// Запись значения в ячейку
Лист.Cells(НомерСтроки, НомерКолонки).Value = ЗначениеЯчейки;

// Сохранение файла
Книга.SaveAs(ИмяФайла);

// Закрытие Эксель и освобождение памяти
Эксель.Quit();
Эксель = 0;

Примеры чтения:

// —— ВАРИАНТ 1 ——

// Создание COM-объекта
Эксель = Новый COMОбъект(«Excel.Application»);
// Открытие книги
Книга = Эксель.Workbooks.Open(ПутьКФайлу);
// Позиционирование на нужном листе
Лист = Книга.Worksheets(1);

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;

  • // Закрытие книги
    Книга.Close(0);
  • // Закрытие Эксель и освобождение памяти
    Эксель.Quit();
    Эксель = 0;
  • // —— ВАРИАНТ 2 ——
  • // Открытие книги
    Книга = ПолучитьCOMОбъект(ПутьКФайлу);
    // Позиционирование на нужном листе
    Лист = Книга.Worksheets(1);

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;

// Закрытие книги
Книга.Application.Quit();

Для обхода всех заполненных строк листа Excel можно использовать следующие приемы:

// —— ВАРИАНТ 1 ——
КоличествоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;
Для НомерСтроки = 1 По КоличествоСтрок Цикл
     ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;
КонецЦикла;

// —— ВАРИАНТ 2 ——
НомерСтроки = 0;
Пока Истина Цикл
     НомерСтроки = НомерСтроки + 1;
     ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;
     Если НЕ ЗначениеЗаполнено(ЗначениеЯчейки) Тогда
         Прервать;
     КонецЕсли;
КонецЦикла;

Вместо последовательного обхода всех строк листа можно выгрузить все данные в массив и работать с ним. Такой подход будет быстрее при чтении большого объема данных:

ВсегоКолонок = Лист.Cells(1, 1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;

Область = Лист.Range(Лист.Cells(1, 1), Лист.Cells(ВсегоСтрок, ВсегоКолонок));
Данные = Область.Value.Выгрузить();

В таблице ниже приведены наиболее востребованные свойства и методы для работы с Excel через OLE:

Действие Код Комментарий
Работа с приложением
Установка видимости окна приложения Эксель.Visible = Ложь;
Установка режима вывода предупреждений (выводить/не выводить) Эксель.DisplayAlerts = Ложь;
Закрытие приложения Эксель.Quit();
Работа с книгой
Создание новой книги Книга = Эксель.WorkBooks.Add();
Открытие существующей книги Книга = Эксель.WorkBooks.Open(ИмяФайла);
Сохранение книги Книга.SaveAs(ИмяФайла);
Закрытие книги Книга.Close(0);
Работа с листом
Установка текущего листа Лист = Книга.WorkSheets(НомерЛиста);
Установка имени Лист.Name = Имя;
Установка защиты Лист.Protect();
Снятие защиты Лист.UnProtect();
Установка ориентации страницы Лист.PageSetup.Orientation = 2; 1 — книжная, 2 — альбомная
Установка левой границы Лист.PageSetup.LeftMargin = Эксель.CentimetersToPoints(Сантиметры);
Установка верхней границы Лист.PageSetup.TopMargin = Эксель.CentimetersToPoints(Сантиметры);
Установка правой границы Лист.PageSetup.RightMargin = Эксель.CentimetersToPoints(Сантиметры);
Установка нижней границы Лист.PageSetup.BottomMargin = Эксель.CentimetersToPoints(Сантиметры);
Работа со строками, колонками, ячейками
Установка ширины колонки Лист.Columns(НомерКолонки).ColumnWidth = Ширина;
Удаление строки Лист.Rows(НомерСтроки).Delete();
Удаление колонки Лист.Columns(НомерКолонки).Delete();
Удаление ячейки Лист.Cells(НомерСтроки, НомерКолонки).Delete();
Установка значения Лист.Cells(НомерСтроки, НомерКолонки).Value = Значение;
Объединение ячеек Лист.Range(Лист.Cells(НомерСтроки, НомерКолонки), Лист.Cells(НомерСтроки1, НомерКолонки1)).Merge();
Установка шрифта Лист.Cells(НомерСтроки, НомерКолонки).Font.Name = ИмяШрифта;
Установка размера шрифта Лист.Cells(НомерСтроки, НомерКолонки).Font.Size = РазмерШрифта;
Установка жирного шрифта Лист.Cells(НомерСтроки, НомерКолонки).Font.Bold = 1; 1 — жирный шрифт, 0 — нормальный
Установка курсива Лист.Cells(НомерСтроки, НомерКолонки).Font.Italic = 1; 1 — курсив, 0 — нормальный
Установка подчеркнутого шрифта Лист.Cells(НомерСтроки, НомерКолонки).Font.Underline = 2; 2 — подчеркнутый, 1 — нет

Для того, чтобы узнать какое свойство нужно менять или какой метод вызвать можно воспользоваться макросами Excel. Если записать макрос с требуемыми действиями, то после можно посмотреть программный код на  VBA записанного макроса.

Использование COMSafeArray

При выгрузке больших объемов данных из 1С в Excel для ускорения можно использовать объект COMSafeArray.

Согласно определению из синтакс-помощника, COMSafeArray — объектная оболочка над многомерным массивом SafeArray из COM. Позволяет создавать и использовать SafeArray для обмена данными между COM-объектами.

Проще говоря, это массив значений, который можно использовать для обмена между приложениями по технологии OLE.

// Создание COMSafeArray
МассивКом = Новый COMSafeArray(«VT_Variant», ВсегоКолонок, ВсегоСтрок);
// Заполнение COMSafeArray
Для Стр = 0 По ВсегоСтрок — 1 Цикл
     Для Кол = 0 По ВсегоКолонок — 1 Цикл
         МассивКом.SetValue(Кол, Стр, Значение);
     КонецЦикла;
КонецЦикла;
// Присвоение области листа Excel значений из COMSafeArray
Лист.Range(Лист.Cells(1, 1), Лист.Cells(ВсегоСтрок, ВсегоКолонок)).Value = МассивКом;

Обмен через ADO

Файл Excel при обмене через ADO представляет собой базу данных, к которой можно обращаться при помощи SQL-запросов. Установка MS Excel не требуется, но обязательно наличие драйвера ODBC, при помощи которого будет осуществляться доступ. Используемый драйвер ODBC определяется при указании строки соединения к файлу. Обычно требуемый драйвер уже установлен на компьютере.

Обмен через ADO заметно быстрее обмена через OLE, но при выгрузке нет возможности использовать функционал Excel для оформления ячеек, разметки страниц, задания формул и т.д.

Пример выгрузки:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект(«ADODB.Connection»);

// Установка строки соединения
Соединение.ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=»+ИмяФайла+«;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;»;
Соединение.Open(); // Открытие соединения

// Создание COM-объекта для команды
Команда = Новый COMОбъект(«ADODB.Command»);
Команда.ActiveConnection = Соединение;

// Присвоение текста команды для создания таблицы
Команда.CommandText = «CREATE TABLE [Лист1] (Колонка1 char(255), Колонка2 date, Колонка3 int, Колонка4 float)»;
Команда.Execute(); // Выполнение команды

// Присвоение текста команды для добавления строки таблицы
Команда.CommandText = «INSERT INTO [Лист1] (Колонка1, Колонка2, Колонка3, Колонка4) values (‘абвгдеё’, ‘8/11/2017’, ‘12345’, ‘12345,6789’)»;
Команда.Execute(); // Выполнение команды

// Удаление команды и закрытие соединения
Команда = Неопределено;
Соединение.Close();
Соединение = Неопределено;

Для создания нового листа и формирования его структуры можно воспользоваться объектами ADOX.Catalog и ADOX.Table. В этом случае код примет вид:

// Создание COM-объекта для работы с книгой
Книга = Новый COMОбъект(«ADOX.Catalog»);
Книга.ActiveConnection = Соединение;

// Создание COM-объекта для работы со структурой данных на листе
Таблица = Новый COMОбъект(«ADOX.Table»);
Таблица.Name = «Лист1»;
Таблица.Columns.Append(«Колонка1», 202);
Таблица.Columns.Append(«Колонка2», 7);
Таблица.Columns.Append(«Колонка3», 5);
Таблица.Columns.Append(«Колонка4», 5);

// Создание в книге листа с описанной структурой
Книга.Tables.Append(Таблица);
Таблица = Неопределено;
Книга = Неопределено;

В приведенном примере в методе

Таблица.Columns.Append(«Колонка1», 202);

во втором параметре указывается тип колонки. Параметр необязательный, вот некоторые значения типа колонки:

  • 5 — adDouble;
  • 6 — adCurrency;
  • 7 — adDate;
  • 11 — adBoolean;
  • 202 — adVarWChar;
  • 203 — adLongVarWChar.

Пример чтения:

// Создание COM-объекта для соединения
Соединение = Новый COMОбъект(«ADODB.Connection»);

// Установка строки соединения
Соединение.ConnectionString = «
|Provider=Microsoft.ACE.OLEDB.12.0;
|Data Source=»+ИмяФайла+«;
|Extended Properties=»»Excel 12.0 XML;HDR=YES»»;»;
Соединение.Open(); // Открытие соединения

// Создание COM-объекта для получения выборки
Выборка = Новый COMОбъект(«ADODB.Recordset»);
ТекстЗапроса = «SELECT * FROM [Лист1$]»;

// Выполнение запроса
Выборка.Open(ТекстЗапроса, Соединение);

// Обход результата выборки
Пока НЕ Выборка.EOF() Цикл
     ЗначениеКолонки1 = Выборка.Fields.Item(«Колонка1»).Value; // Обращение по имени колонки
ЗначениеКолонки2 = Выборка.Fields.Item(0).Value; // Обращение по индексу колонки
     Выборка.MoveNext();
КонецЦикла;

Выборка.Close();
Выборка = Неопределено;
Соединение.Close();
Соединение = Неопределено;

В строке соединения параметр HDR определяет как будет восприниматься первая строка на листе. Возможны варианты:

  • YES — первая строка воспринимается как названия колонок. К значениям можно обращаться по имени и по индексу колонки.
  • NO — первая строка воспринимается как данные. К значениям можно обращаться только по индексу колонки.

В приведенных примерах рассмотрено лишь несколько объектов ADO. Объектная модель ADO состоит из следующих объектов:

  • Connection;
  • Command;
  • Recordset;
  • Record;
  • Fields;
  • Stream;
  • Errors;
  • Parameters;
  • Properties.

Выгрузка без программирования

Для сохранения данных из 1С в Excel не всегда целесообразно прибегать к программированию. Если в режиме Предприятия пользователь может отобразить требуемые для выгрузки данные, то, их возможно сохранить в Excel без программирования.

  1. Для сохранения табличного документа (например, результата отчета) можно вызвать команду Сохранить или Сохранить как… главного меню.
  2. Как из файла excel в сделать макет для 1с?
  3. В открывшемся окне требуется выбрать каталог, имя и формат сохраняемого файла.
  4. Для сохранения данных динамических списков (например, списка номенклатуры) необходимо:
  1. Вывести данные в табличный документ при помощи команды Еще ⇒ Вывести список…;
  2.   Сохранить табличный документ в требуемый формат.

Как из файла excel в сделать макет для 1с?
 

Остались вопросы?
Спросите в х к статье.

Смотри также:

Преобразование объекта XDTO в текст
Работа с файлами DBF
Основные способы обмена 1С с другими системами

Источник: https://pro1c8.ru/obmen-excel-1c/

Загрузка из Excel в 1С 8.3 и 8.2 для программиста — в накладные и в табличный документ

MS Excel на данный момент является одной из самых распространенных и любимых программ для работы с электронными таблицами. Поэтому зачастую программистам приходится сталкиваться с просьбами пользователей загрузить Excel файл в 1С 8.3.

Ниже будут рассмотрены два способа загрузки: в документ (накладная или установка цены) и в табличный документ. Получившиеся обработку можно скачать по ссылке.

Загрузка из Excel в документ 1С

В качестве примера выберем такой документ, как «Установка цен номенклатуры» в программе 1С Бухгалтерия 3.0. Задачей будет создать документ, заполнить основные реквизиты шапки и заполнить табличную часть «Товары» из Excel файла.

1 шаг – интерфейс

В рамках данной задачи достаточно разместить на форме поле ввода с кнопками выбора, очистки и открытия для выбора файла Excel и кнопку «Загрузить» для выполнения обработки по созданию и заполнению документа «Установка цен номенклатуры».

Читайте также:  Как сделать чек в access?

Как из файла excel в сделать макет для 1с?

2 шаг – процедура выбора файла

Для того чтобы открыть и выбрать Excel файл из 1С 8.3, необходимо в событии «НачалоВыбора» поля ввода вызвать ДиалогВыбораФайла с заранее установленным фильтром:

Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); Диалог.Заголовок = «Выберите excel — файл»; Диалог.ПолноеИмяФайла = «c:»; Диалог.Фильтр = «Таблицы (*.xls,*.xlsx)|*.xls;*.xlsx;|Microsoft Excel 97/2000/XP/2003 (*.xls)|*.xls|Microsoft Excel 2007/2010 (*.xlsx)|*.xlsx»; Если Диалог.Выбрать() Тогда Объект.ФайлExcel = Диалог.ПолноеИмяФайла; КонецЕсли;

Для работы на web-клиенте, в браузере необходимо подключить расширение работы с файлами.

3 шаг – обработка файла Excel

В рамках данного шага реализуется открытие файла Excel, выбор первого листа (по желанию можно выбрать любой другой), расчет количества строк и колонок с данными.

// Попытка открытия файла Excel Попытка Excel = Новый COMОбъект(«Excel.Application»); Excel.WorkBooks.Open(Объект.ФайлExcel); Исключение Сообщить(«При открытии файла произошла ошибка! Операция прервана!»); Сообщить(ОписаниеОшибки()); Возврат; КонецПопытки; // Попытка выбрать первый лист // Можно указать любой другой Попытка Excel.Sheets(1).Select(); Исключение // Закрытие файла в том случае, если первый лист не найден Excel.ActiveWorkbook.Close(); Excel = 0; Сообщить(«Первый лист не найден!»); ОтменитьТранзакцию(); Возврат; КонецПопытки; // Вычисление количества строк и колонок в зависимости от версии Excel vExcel = Лев(Excel.Version, Найти(Excel.Version,».»)-1); Если vExcel = «8» тогда КоличествоСтрок = Excel.Cells.CurrentRegion.Rows.Count; КоличествоКолонок = Макс(Excel.Cells.CurrentRegion.Columns.Count, 13); Иначе КоличествоСтрок = Excel.Cells(1,1).SpecialCells(11).Row; КоличествоКолонок = Excel.Cells(1,1).SpecialCells(11).Column; Конецесли;

4 шаг – создание документа и заполнение его данными

После того, как файл Excel успешно открыт и были получены все необходимые данные, можно приступать к созданию документа и его заполнению.

Ниже приведен алгоритм, которым можно воспользоваться в том случае, если файл содержит множество колонок, но загрузить нужно лишь те, которые есть в документе 1С. Так же его можно использовать, когда есть необходимость проверить имена колонок на соответствие именам реквизитов для исключения ошибок.

// Проверка корректности заполнения колонок // Имена колонок в Excel файле должны совпадать с именами реквизитов табличной части, в которую загружаются данные // Переменная МассивКолонок содержит список номеров колонок, которые будут перегружаться МассивКолонок = Новый ТаблицаЗначений; МассивКолонок.Колонки.Добавить(«НомерКолонки»); МассивКолонок.Колонки.Добавить(«НазваниеКолонки»); Для КолонкаОтсчета = 1 по КоличествоКолонок Цикл ИмяКолонки = Excel.Cells(1, КолонкаОтсчета).Text; // Удаление лишних пробелов из имен колонок ИмяБезПробелов = СтрЗаменить(ИмяКолонки,» «,»»); // Проверка наличия реквизитов табличной части «Товары» в документе «УстановкаЦен» Если НЕ НаличиеРеквизитаТЧ(ИмяБезПробелов, Метаданные.Документы.УстановкаЦенНоменклатуры, «Товары») Тогда Сообщить(«Не найден реквизит с именем » + ИмяБезПробелов + «! Колонка не будет загружена!»); Иначе НовСтрока = МассивКолонок.Добавить(); НовСтрока.НомерКолонки = КолонкаОтсчета; НовСтрока.НазваниеКолонки = ИмяБезПробелов; КонецЕсли; КонецЦикла;

Вызываемая функция «НаличиеРеквизитаТЧ(ИмяРекв, МетаданныеДок, ИмяТЧ)» проверяет в метаданных документа наличие реквизита выбранной нами табличной части (в данном случае «Товары») по его имени. Функция является универсальной, но если на практике задача загрузки файлов из Excel встречается не часто можно вместо нее сразу указать имена реквизитов табличной части документа для сравнения.

// Проверка наличия реквизита табличной части документа // Возвращает тип Булево // Истина — реквизит найден // Ложь — реквизит не найден &НаСервере Функция НаличиеРеквизитаТЧ(ИмяРекв, МетаданныеДок, ИмяТЧ) // Проверка наличия ТЧ ТЧ = МетаданныеДок.ТабличныеЧасти.Найти(ИмяТЧ); Если ТЧ = Неопределено Тогда // Нет такой таб. части в документе Возврат Ложь; Иначе Возврат НЕ (ТЧ.Реквизиты.Найти(ИмяРекв) = Неопределено); КонецЕсли; КонецФункции

После того, как был сформирован список загружаемых колонок, нужно приступать  к созданию и заполнению самого документа. В данном примере обязательным условием является наличие в файле Excel колонки с названием «Номенклатура» потому что данный реквизит является обязательным к заполнению.

// Если есть колонки для загрузки // и есть колонка «Номенклатура, которая является обязательным к заполнению реквизитом Если МассивКолонок.Количество() 0 и МассивКолонок.НайтиСтроки(Новый Структура(«НазваниеКолонки», «Номенклатура»)).Количество() 0 Тогда // Создание документа и заполнение реквизитов шапки НовыйДокумент = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент(); НовыйДокумент.Дата = ТекущаяДата(); НовыйДокумент.ТипЦен = Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию(«Оптовая цена», Истина); НовыйДокумент.Ответственный = ПараметрыСеанса.ТекущийПользователь; НовыйДокумент.Комментарий = «Загружено из файла » + Объект.ФайлExcel; // Заполнение табличной части «Товары» // Переменная СтрокаОтсчета — номер строки в Excel, с которой начинается заполнение Для СтрокаОтсчета = 2 по КоличествоСтрок Цикл НСтр = НовыйДокумент.Товары.Добавить(); НСтр.Валюта = НовыйДокумент.ТипЦен.ВалютаЦены; Для каждого СтрокаМассив из МассивКолонок Цикл ТекущееЗначение = Excel.Cells(СтрокаОтсчета, СтрокаМассив.НомерКолонки).Text; // Получение имени колонки ИмяКолонки = Excel.Cells(1, СтрокаМассив.НомерКолонки).Text; // Заполнение строки данными Если ИмяКолонки = «Номенклатура» Тогда НСтр.Номенклатура = Справочники.Номенклатура.НайтиПоНаименованию(ТекущееЗначение, Истина); ИначеЕсли ИмяКолонки = «Цена» Тогда НСтр.Цена = ТекущееЗначение; КонецЕсли; КонецЦикла; КонецЦикла; // Запись и проведение документа НовыйДокумент.Записать(РежимЗаписиДокумента.Проведение); Сообщить(«Создан и заполнен документ » + Строка(НовыйДокумент)); Иначе Сообщить(«В Excel файле не достаточно данных для заполнения документа!»); КонецЕсли;

В результате данной обработки был создан, заполнен данными и проведен документ «Установка цен номенклатуры».

После завершения всех манипуляций с Excel файлом, его необходимо закрыть:

Excel.DisplayAlerts = 0; Excel.Quit(); Excel.DisplayAlerts = 1;

Загрузка данных из Excel в табличный документ

Начиная с версии платформы 8.3.6, фирма 1С добавила очень полезный метод, который позволяет загружать данные из Excel в табличный документ 1С. Данный метод применим для таких форматов, как *.xlsx, *.xls, *, ods.

В версии технологической платформы 1C 8.3.10 данный метод позволяет считывать отдельные листы файла, а не весь документ целиком.

Данный функционал реализован в виде метода «Прочитать» у объекта с типом «ТабличныйДокумент».

В качестве примера добавим на форму обработки табличный документ, куда будет выводиться Excel файл и кнопку со следующим кодом, выполняющимся на сервере:

ТабличныйДокумент.Прочитать(Объект.ФайлExcel);

В качестве параметра методу передается адрес нахождения файла текстовой строкой. Для больших файлов Excel данный метод может отрабатывать значительное время.

Результатом выполнения этого кода будет являться табличный документ с данными из Excel и сохранением оформления, что является весьма приятным бонусом. В рассмотренном примере исходный файл Excel содержал два листа, на каждом из которых была таблица. Результат метода «Прочитать» изображен ниже:

  • Как из файла excel в сделать макет для 1с?
  • Смотрите также видео о загрузке с помощью типовой обработки:

Источник: https://1s83.info/programmirovanie/zagruzka-iz-excel-v-1s-dlya-programmista.html

v8.3: Как в макет вставить эксель файл

Feliks1961

15.12.2015 12:14 Прочитано: 3969
  • На макете создал область макета с именем- ОбластьЛистаЭкселя.
  • Далее
  • Таблица — Рисунок — Вставить объект

Создаю объект. Создать новый и в качестве объект выбираю — Лист Microsoft Office Excel.Имяобъекта- ОбъектВ модулехЭксель = «D:list.xls»; // Состоит из одного листа но в нем картинки, выноски и т.д. Создает пользователь сам и что в нем неясно(т.е. на листе может быть все , что угодно).ТабличныйДокумент = Новый ТабличныйДокумент;ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;

  1. ТабличныйДокумент.АвтоМасштаб = Истина;
  2. ТабличныйДокумент.ПолеСверху = 5;
  3. ТабличныйДокумент.ПолеСнизу = 10;
  4. ОбластьКартинкиСтрока = Макет.ПолучитьОбласть(«ОбластьЛистаЭкселя»);

Рисунок= ОбластьКартинкиСтрока.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Объект);

  • Рисунок.Верх =9;
  • Рисунок.Высота = 175;
  • Рисунок.Ширина = 165;
  • Рисунок.Лево = 8;
  • Рисунок.Объект = хЭксель;
  • ТабличныйДокумент.Вывести(ОбластьКартинкиСтрока);

При запуске выдает ошибку «Поле объекта недоступно для записи». Что я делаю не так? Понимаю, что должно быть такРисунок.Объект = Новый ? (хЭксель), а вот, что поставить вместо ? незнаю. Помогите.

Yandex

Возможно, вас также заинтересует
Как из файла excel в сделать макет для 1с?
Feliks1961

15.12.2015 12:27 Ответ № 1
Попробовал такЭксель = Новый COMОбъект(«Excel.Application»); Книга = Эксель.WorkBooks.Open(ПутьДоЛистаЭкселя); Лист =  Книга.WorkSheets(1); Рисунок.Объект = Лист; Эксель.Application.Quit();Ошибка «Поле объекта недоступно для записи».
E_Migachev

16.12.2015 15:34 Ответ № 2
Делал что-то аналогичное, в итоге отказались от этого, т.к. у всех пользователей это поле по разному криво отображалось, в итоге сделали загрузку информации из файла в ТЗ и вывод в табличный документ.Почему у тебя поле называется рисунок? там должен быть активХ компанент Ексель
Подсказка: Для быстрого поиска ответов — используйте 'Поиск'

Источник: https://helpf.pro/help/view/16905.html

Создание нового Excel(Эксель) файла в 1с

Страница актуализирована: 06.02.2017

Создать Эксель файл в 1с.

Как создать эксель(Excel) файл в 1с?
Просто приведу пример кода создания эксель файла в 1с. В нем есть всё необходимое.

Открыть, сформировать строки, задать форматы, сохранить и закрыть.

// Формирование нового файла
Эксель = Новый COMОбъект(«Excel.Application»);
Книга = Эксель.WorkBooks.Add();
Эксель.

ScreenUpdating = 0;
Эксель.Calculation = -4135;
Лист = Книга.WorkSheets(1);

// сформировать шапку выходного файла

Лист.Cells(1, 1).Value = «РџРѕСЃС‚авщик: наименование»; Лист.Columns(1).ColumnWidth = 18;
Лист.Cells(1, 2).Value = «РџРѕСЃС‚авщик: Р�РќРќ/РљРџРџ»; Лист.Columns(2).ColumnWidth = 10;
Лист.Cells(1, 3).Value = «РџРѕСЃС‚авщик: адрес»; Лист.Columns(3).

ColumnWidth = 45;
Лист.Cells(1, 4).Value = «Р“рузополучатель: наименование»; Лист.Columns(4).ColumnWidth = 18;
Лист.Cells(1, 5).Value = «Р“рузополучатель: Р�РќРќ/РљРџРџ»; Лист.Columns(5).ColumnWidth = 9;
Лист.Cells(1, 6).

Value = «Р“рузополучатель: адрес»;    Лист.Columns(6).ColumnWidth = 45;
Лист.Cells(1, 7).Value = «РљРѕРґ РІРёРґР° продукции»; Лист.Columns(7).ColumnWidth = 8;
Лист.Cells(1, 8).Value = «РќР°РёРјРµРЅРѕРІР°РЅРёРµ РІРёРґР° продукции»; Лист.Columns(8).

ColumnWidth = 15;
Лист.Cells(1, 9).Value = «РќРѕРјРµРЅРєР»Р°С‚СѓСЂР°»; Лист.Columns(9).ColumnWidth = 45;
Лист.Cells(1,10).Value = «РџРµСЂРёРѕРґ»; Лист.Columns(10).ColumnWidth = 8;
Лист.Cells(1,11).Value = «РћР±СЉРµРј»; Лист.Columns(11).ColumnWidth = 8;
Лист.Cells(1,12).

Value = «РљРѕР»РёС‡РµСЃС‚РІРѕ»; Лист.Columns(12).ColumnWidth = 8;

// записать одну строку

// Цикл по НомерСтроки
Лист.Cells(НомерСтроки, 1).Value = _ПоставщикНаименование;
Лист.Cells(НомерСтроки, 2).Value = _Поставщик�ННКПП;
Лист.Cells(НомерСтроки, 3).Value = _ПоставщикАдрес;
Лист.Cells(НомерСтроки, 4).Value = _ГрузополучательНаименование;
Лист.Cells(НомерСтроки, 5).Value = _Грузополучатель�ННКПП;
Лист.Cells(НомерСтроки, 6).Value = _ГрузополучательАдрес;
Лист.Cells(НомерСтроки, 7).Value = _ВидПродукции;
Лист.Cells(НомерСтроки, 8).Value = _ВидПРодукцииНаименование;
Лист.Cells(НомерСтроки, 9).Value = _Номенклатура;
Лист.Cells(НомерСтроки,10).Value = Период;
// КонецЦикла

// прописать форматы ячеек

Лист.Range(Лист.Cells(1, 1), Лист.Cells(1, 12)).Font.Bold = 1;                        //Жирный шрифт РІ шапке
Лист.Range(Лист.Cells(1, 1), Лист.Cells(НомерСтроки, 12)).WrapText = Р�стина;         //Перенос текста РїРѕ словам
Лист.

Range(Лист.Cells(1, 1), Лист.Cells(НомерСтроки, 12)).Borders.Linestyle = 1;     //Установка границ ячеек
Лист.Range(Лист.Cells(1, 1), Лист.Cells(НомерСтроки, 12)).Font.Size = 8;             //Размер шрифта
Лист.Range(Лист.

Cells(1, 1), Лист.Cells(НомерСтроки, 12)).VerticalAlignment = 2; //Центрирование по вертикали
Лист.Range(Лист.Cells(1, 1), Лист.Cells(НомерСтроки, 12)).

HorizontalAlignment = 3; //Центрирование по горизонтали

// Сохранить итоговый файл

Эксель.DisplayAlerts=0;
Книга.SaveAs(�мя�тоговогоФайла,-4143);
РљРЅРёРіР°.Close();
Эксель.DisplayAlerts=1;
Эксель.Quit();

Источник: http://www.1c-forever.ru/3_005_00009.html

Ссылка на основную публикацию
Adblock
detector