Как сделать чтобы excel считал округленные числа?

Как сделать чтобы excel считал округленные числа?

При выполнении деления или работе с дробными числами, Excel производит округление. Это связано, прежде всего, с тем, что абсолютно точные дробные числа редко когда бывают нужны, но оперировать громоздким выражением с несколькими знаками после запятой не очень удобно. Кроме того, существуют числа, которые в принципе точно не округляются. В то же время, недостаточно точное округление может привести к грубым ошибкам в ситуациях, где требуется именно точность. К счастью, в программе имеется возможность пользователям самостоятельно устанавливать, как будут округляться числа.

Особенности округления чисел Excel

Все числа, с которыми работает Microsoft Excel, делятся на точные и приближенные. В памяти хранятся числа до 15 разряда, а отображаются до того разряда, который укажет сам пользователь. Все расчеты выполняются согласно хранимых в памяти, а не отображаемых на мониторе данных.

С помощью операции округления Эксель отбрасывает некоторое количество знаков после запятой. В нем применяется общепринятый способ округления, когда число меньше 5 округляется в меньшую сторону, а больше или равно 5 – в большую сторону.

Округление с помощью кнопок на ленте

Самый простой способ изменить округление — это выделить ячейку или группу ячеек и, находясь на вкладке «Главная», нажать на ленте на кнопку «Увеличить разрядность» или «Уменьшить разрядность». Обе кнопки располагаются в блоке инструментов «Число». Будет округляться только отображаемое число, но для вычислений при необходимости будут задействованы до 15 разрядов чисел.

При нажатии на кнопку «Увеличить разрядность» количество внесенных знаков после запятой увеличивается на один.

Как сделать чтобы excel считал округленные числа?

Кнопка «Уменьшить разрядность», соответственно, уменьшает на одну количество цифр после запятой.

Как сделать чтобы excel считал округленные числа?

Округление через формат ячеек

Есть возможность также выставить округление с помощью настроек формата ячеек. Для этого нужно выделить диапазон ячеек на листе, кликнуть правой кнопкой мыши и в появившемся меню выбрать пункт «Формат ячеек».

Как сделать чтобы excel считал округленные числа?

В открывшемся окне настроек формата ячеек следует перейти на вкладку «Число». Если формат данных указан не числовой, необходимо выставить именно его, иначе вы не сможете регулировать округление. В центральной части окна около надписи «Число десятичных знаков» просто укажите цифрой то количество знаков, которое желаете видеть при округлении. После этого примените изменения.

Как сделать чтобы excel считал округленные числа?

Установка точности расчетов

Если в предыдущих случаях устанавливаемые параметры влияли только на внешнее отображения данных, а при расчетах использовались более точные показатели (до 15 знака), то сейчас мы расскажем, как изменить саму точность расчетов.

  1. Перейдите на вкладку «Файл», оттуда — в раздел «Параметры».
  2. Как сделать чтобы excel считал округленные числа?

  3. Откроется окно параметров Excel. В этом окне зайдите в подраздел «Дополнительно». Отыщите блок настроек под названием «При пересчете этой книги». Настройки в этом блоке применяются не к одному листу, а к книге в целом, то есть ко всему файлу. Поставьте галочку напротив параметра «Задать точность как на экране» и нажмите «OK».
  4. Как сделать чтобы excel считал округленные числа?

  5. Теперь при расчете данных будет учитываться отображаемая величина числа на экране, а не та, которая хранится в памяти Excel. Настройку же отображаемого числа можно провести любым из двух способов, о которых мы говорили выше.

Применение функций

Если же вы хотите изменить величину округления при расчете относительно одной или нескольких ячеек, но не хотите понижать точность расчетов в целом для документа, в этом случае лучше всего воспользоваться возможностями, которые предоставляет функция «ОКРУГЛ» и различные ее вариации, а также некоторые другие функции.

Среди основных функций, которые регулируют округление, следует выделить такие:

  • «ОКРУГЛ» – округляет до указанного числа десятичных знаков согласно общепринятым правилам округления;
  • «ОКРУГЛВВЕРХ» – округляет до ближайшего числа вверх по модулю;
  • «ОКРУГЛВНИЗ» – округляет до ближайшего числа вниз по модулю;
  • «ОКРУГЛТ» – округляет число с заданной точностью;
  • «ОКРВВЕРХ» – округляет число с заданной точностью вверх по модулю;
  • «ОКРВНИЗ» – округляет число вниз по модулю с заданной точностью;
  • «ОТБР» – округляет данные до целого числа;
  • «ЧЕТН» – округляет данные до ближайшего четного числа;
  • «НЕЧЕТН» – округляет данные до ближайшего нечетного числа.

Для функций «ОКРУГЛ», «ОКРУГЛВВЕРХ» и «ОКРУГЛВНИЗ» используется следующий формат ввода: Наименование функции (число;число_разрядов). То есть если вы, к примеру, хотите округлить число 2,56896 до трех разрядов, то применяете функцию «ОКРУГЛ(2,56896;3)». В итоге получается число 2,569.

Как сделать чтобы excel считал округленные числа?

Для функций «ОКРУГЛТ», «ОКРВВЕРХ» и «ОКРВНИЗ» применяется такая формула округления: Наименование функции(число;точность). Так, чтобы округлить цифру 11 до ближайшего числа, кратного 2, вводим функцию «ОКРУГЛТ(11;2)». На выходе получается результат 12.

Как сделать чтобы excel считал округленные числа?

Функции «ОТБР», «ЧЕТН» и «НЕЧЕТ» используют следующий формат: Наименование функции(число). Для того чтобы округлить цифру 17 до ближайшего четного, применяем функцию «ЧЕТН(17)». Получаем результат 18.

Как сделать чтобы excel считал округленные числа?

Функцию можно вводить, как в ячейку, так и в строку функций, предварительно выделив ту ячейку, в которой она будет находиться. Перед каждой функцией следует ставить знак «=».

Существует и несколько другой способ введения функций округления. Его особенно удобно использовать, когда есть таблица со значениями, которые нужно преобразовать в округленные числа в отдельном столбике.

  1. Переходим во вкладку «Формулы» и кликаем по кнопке «Математические». В открывшемся списке выбираем подходящую функцию, например, «ОКРУГЛ».
  2. После этого открывается окно аргументов функции. В поле «Число» можно ввести число вручную, но если мы хотим автоматически округлить данные всей таблицы, тогда кликаем по кнопке справа от окна введения данных.
  3. Окно аргументов функции сворачивается. Теперь щелкнуте по самой верхней ячейке столбца, данные которого мы собираемся округлить. После того, как значение занесено в окно, жмем по кнопке справа от этого значения.
  4. Опять открывается окно аргументов функции. В поле «Число разрядов» записываем разрядность, до которой нам нужно сокращать дроби и применяем изменения.
  5. Число округлилось. Чтобы таким же образом округлить и все другие данные нужного столбца, наводим курсор на нижний правый угол ячейки с округленным значением, жмем на левую кнопку мыши, и протягиваем ее вниз до конца таблицы.
  6. Теперь все значения в столбце будут округлены.

Как видим, существуют два основных способа округлить видимое отображение числа: с помощью кнопки на ленте и путем изменения параметров формата ячеек. Кроме того, можно изменить и округление реально рассчитываемых данных.

Это также можно сделать по-разному: изменением настроек книги в целом или применением специальных функций.

Выбор конкретного метода зависит от того, собираетесь ли вы применять подобный вид округления для всех данных в файле или только для определенного диапазона ячеек.

Мы рады, что смогли помочь Вам в решении проблемы.

Опишите, что у вас не получилось.
Наши специалисты постараются ответить максимально быстро.

Помогла ли вам эта статья?

ДА НЕТ

Источник: https://lumpics.ru/rounding-numbers-in-excel/

Как округлить число в Excel при помощи функций: подробная инструкция

Светлана Гайворонская

02 ноября 2019 в 11:53

Здравствуйте, друзья.

К таблицам у всех нас разное отношение, кто-то их очень любит и “рисует” по каждому поводу, кто-то терпеть не может. Но всем нам иногда приходится с ними работать, поэтому полезно знать основные возможности табличного редактора и дополнительные фишки, например, закрепление строк, использование сортировки и фильтров. Такие инструменты могут здорово облегчить жизнь.

Сегодня же мы говорим о том, как округлить число в Excel, какие есть способы, для чего это нужно, и как правильно применять функции.

Способы

Под округлением каждый из нас может понимать что-то свое, поэтому давайте рассмотрим, какие варианты есть в Excel:

  1. Простое отбрасывание дробной части. Например, у нас есть число 12,3456, мы же хотим видеть только десятые и сотые доли, большая точность нас не интересует. Отбрасыванием дробной части мы получим результат 12,34. Такой способ часто используется для красоты, чтобы не перегружать таблицу и себя лишними знаками. В таком случае для решения задачи можно использовать формат ячеек.
  2. Математическое округление. В данном случае часть знаков после запятой отбрасывается, но при этом учитывается следующая цифра после значимого для нас разряда. Мы смотрим, она больше 5 или меньше. Например, у нас есть число 12,57. Мы хотим округлить его до десятых. Тогда по правилам математики мы получаем 12,6. То есть мы увеличили десятые доли на 1, потому что сотые больше 5. Если бы мы округляли 12,52, то получили бы 12,5.
  3. Округление до ближайшего большего или меньшего числа, так называемое округление “вверх” и округление “вниз” соответственно. Например, у нас есть исходные данные: 12,75, 12,31, 11,89, которые мы хотим преобразовать в целые величины. Если мы используем округление “вниз”, то получим 12, 12, 11. Если округляем в большую сторону, то получим 13, 13, 12.
  4. Округление до десятков, сотен, тысяч и так далее. Этот вариант бывает полезен, когда нам нужны приблизительные вычисления, без детализации.
  5. Округление до ближайшего четного и нечетного значения.
  6. Округление до ближайшего кратного какой-то величине числа. Например, у нас есть 124 конфеты, а в 1 коробку вмещается 13 конфет. И мы хотим понять, сколько конфет у нас разместится в коробках по 13 штук. Тогда мы будем округлять 124 до меньшего целого числа кратного 13 и получим результат 117.
Читайте также:  Как сделать импорт из word в excel?

Для каждого из этих случаев в Excel есть своя функция округления. Давайте научимся ими пользоваться. Но сначала посмотрим, как можно изменить внешний вид данных в таблице.

Формат ячеек

Часто нам нужно не фактическое округление, а просто аккуратный единый вид всех чисел в таблице. В таком случае мы не используем формулы, а просто меняем внешний вид данных.

Для этого выделяем ячейки в таблице и нажимаем правую кнопку мыши. В контекстном меню выбираем нужный раздел.

Как сделать чтобы excel считал округленные числа?

Во вкладке “Число” выбираем подходящий формат.

Как сделать чтобы excel считал округленные числа?

“Общий” используется по умолчанию и отображает данные в ячейках так, как они есть, изменить внешний вид тут не получится.

Как сделать чтобы excel считал округленные числа?

“Числовой” позволяет отображать столько знаков после запятой, сколько нужно, или вовсе убрать дробную часть.

Как сделать чтобы excel считал округленные числа?

“Денежный” и “Финансовый” похожи на “Числовой”, но позволяют также указывать валюту.

Как сделать чтобы excel считал округленные числа?

В “Процентном” тоже можно регулировать количество знаков после запятой. Если мы переключаемся на этот формат, то исходные данные в ячейках умножаются на 100, и добавляется значок %.

Как сделать чтобы excel считал округленные числа?

Я для своих вычислений чаще всего пользуюсь числовым форматом. Он универсальный и позволяет быстро привести ячейки к единому виду.

Как сделать чтобы excel считал округленные числа?

Этот способ подходит для Excel любого года выпуска. Если у вас новая версия программы, то решить задачу можно еще быстрее. Для этого во вкладке “Главная” есть специальный блок опций. Тут можно выбрать подходящий формат из выпадающего списка, а стрелочками влево и вправо увеличить или уменьшить количество разрядов.

Как сделать чтобы excel считал округленные числа?

Внимание: при изменении формата данных фактические значения в ячейках не меняются, они остаются прежними, просто отображаются по-другому.

Как сделать чтобы excel считал округленные числа?

Как работать с функциями в Excel

Мы рассмотрели самый простой способ убрать лишние знаки. Использовать его довольно удобно, если менять сами данные в таблице нам не нужно. Теперь мы переходим к использованию различных функций. Но сначала я хочу напомнить вам, что это такое, а также как с ними работать.

Функции ускоряют и упрощают вычисления. Например, нам надо посчитать сумму в столбце, в котором 100 значений. Мы можем делать это самым прямым способом “1+20+30+43…” и так 99 раз. Или написать встроенную команду “СУММ”, указать диапазон ячеек, и программа за секунду сделает расчеты.

Первый способ

Чтобы вручную написать формулу в ячейке с использованием функции, обязательно нужно:

  1. Поставить знак =.
  2. Правильно указать название.
  3. Открыть круглую скобку.
  4. Указать через точку с запятой аргументы, то есть данные, которые будут использоваться.
  5. Закрыть скобку.

Что может выступать аргументом математических формул:

  • число,
  • формула,
  • диапазон ячеек.

Пример: функция “=СУММ(F21:F30)” посчитает сумму чисел, написанных в столбце F с позиции F21 до F30.

Эти правила нужно запомнить, иначе программа не сможет сделать вычисления, а будет выдавать ошибку такого вида.

Как сделать чтобы excel считал округленные числа?

Второй способ

Если неудобно писать команды вручную, то можно воспользоваться библиотекой, которая находится во вкладке “Формулы”.

Нас в данный момент интересуют математические операции. Нажимаем на соответствующий раздел и выбираем нужную процедуру.

Откроется диалоговое окно, в котором легко понять, какие аргументы нужно указать. Заполните поля и нажмите “ОК”.

Отбрасывание дробной части

Этот способ подойдет, если нам не важно, произойдет ли округление по математическим законам, и в какую сторону изменится значение. Когда мы просто хотим упростить вычисления, убрав лишние знаки, то можем отбросить их. Для этого есть функция “ОТБР”, которая содержит 2 параметра:

  • число, над которым нужно произвести действие;
  • количество знаков после запятой, которое следует оставить.

Например, у нас есть цена товара 4 716 рублей 77 копеек и еще уйма знаков после запятой. Логично отбросить все лишнее и получить только рубли и копейки.

  • Если же мы хотим получить только рубли без копеек, то вторым аргументом пишем не 2, а 0.

Математическое округление

Для привычного нам со школы математического действия есть специальная функция “ОКРУГЛ”. Она нужна для работы с дробными частями и целочисленными значениями. Аргументами выступают число и количество разрядов, которые нужно оставить после запятой.

Например, у нас есть значение 34,83021, и мы хотим округлить его с точностью до сотых. Тогда формула будет выглядеть так: “=ОКРУГЛ(34,83021;2)”.

Если в качестве второго аргумента указать 0, то получим целочисленное значение, то есть округлим первоначальные данные до единиц. А если количество разрядов будет отрицательным, то преобразовываться будет уже целое число.

Например, мы хотим округлить до сотен 1245,329. Тогда делаем такую запись в ячейке нашей таблицы: “=ОКРУГЛ(1245,329;-2)” и получаем результат 1 200.

В меньшую и большую сторону

Бывает так, что нам не нужно точное математическое вычисление, а важно не преувеличить или, наоборот, не уменьшить значение в ячейке. Тогда мы будем округлять в меньшую или большую сторону.

До дробных частей

Чтобы округлить в меньшую или большую сторону, есть универсальные функции “ОКРУГЛВНИЗ” и “ОКРУГЛВВЕРХ”. Они позволяют делать преобразования с точностью до целых и дробных частей.

Первый аргумент – это число, которое требуется округлить. Второй – количество разрядов. Если он больше 0, то показывает, сколько знаков после запятой должно остаться, если меньше 0, то происходит округление до десятков, сотен, тысяч. Если аргумент равен 0, то мы получаем точность до единиц, дробная часть отбрасывается.

Давайте посмотрим на примере работу этих двух команд.

До целых

Есть еще один способ округлить в меньшую или большую сторону. Для этого нам понадобятся функции “ОКРВНИЗ” и “ОКРВВЕРХ”. Они применяются для получения целочисленного результата.

Второй аргумент показывает, до какого разряда мы округляем:

  • 10 – до десятков;
  • 100 – до сотен;
  • 1 000 – до тысяч и т. д.

Показываю на примере.

Округление “вниз” до единиц можно заменить функцией “ЦЕЛОЕ”, у которой есть единственный аргумент – число. Результат будет таким же, как при использовании “ОКРВНИЗ”.

Округлить в большую сторону до ближайшего четного или нечетного целого значения помогают действия “ЧЁТН” и “НЕЧЁТ”. Пример использования одного из них вы видите на скриншоте.

До целых с учетом кратности

Помните пример с конфетами, который был в начале статьи? Сейчас мы научимся округлять до ближайшего кратного какой-то величине значения. Для этого служат 2 функции: “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Первая уменьшает исходную величину, а вторая соответственно увеличивает.

Например, у нас есть число 124, и мы хотим округлить его до ближайшего большего кратного 5 значения. Тогда пишем в ячейке: “=ОКРВВЕРХ.МАТ(124;5)” и в результате получаем 125.

Источник: https://iklife.ru/dlya-novichka/kak-okruglit-chislo-v-excel-posle-zapyatoj.html

Как округлять числа в Excel

В статье рассмотрено, как округлить число в Excel с помощью различных функций, таких как ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ и другие методы округления. Также приведены примеры формул, как округлить до целого числа, до десятых, до тысяч, до 5, 10 или 100, как округлить кратному числу, а также много других примеров.

Округлить число в путем изменения формата ячейки

Если вы хотите округлить числа в Excel исключительно для визуальной презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  1. Выберите ячейку с числами, которые вы хотите округлить.
  2. Откройте диалоговое окно «Формат ячеек», нажав Ctrl+1 или щелкните правой кнопкой мыши по ячейке и выберите «Формат ячеек» в контекстном меню.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Формат ячеек

  1. Во вкладке «Число» выберите «Числовой» или «Денежный» формат и введите число десятичных знаков, которое вы хотите отобразить в поле «Число десятичных знаков».

    Предварительный просмотр, как будет округлено число отобразится в разделе «Образец».

  2. Нажмите кнопку «ОК», чтобы сохранить изменения и закрыть диалоговое окно.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Округлить число, изменением формата ячейки

Обратите внимание! Этот метод изменяет формат отображения без изменения фактического значения, хранящегося в ячейке. Если вы ссылаетесь на эту ячейку в любых формулах, то во всех вычислениях будет использоваться исходное число без округления. Если вам необходимо фактически округлить число в ячейке, то используйте функции округления Excel.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис: Как сделать чтобы excel считал округленные числа?

Число — любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов — количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Как округлить число до тысячных

  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Примеры формул, как округлить число, функцией ОКРУГЛ

Как округлить число в большую сторону функцией ОКРУГЛВВЕРХ

  • Функция ОКРУГЛВВЕРХ округляет число вверх (от 0) до заданного количества цифр.
  • Синтаксис: Как сделать чтобы excel считал округленные числа?
  • Число — число для округления.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Вы можете указать как положительные, так и отрицательные числа в этом аргументе, и он работает как число_разрядов функции ОКРУГЛ, описанной выше, за исключением того, что число всегда округляется в большую сторону.

Как сделать чтобы excel считал округленные числа?

Как округлить число в Excel – Примеры формул, как округлить число в большую сторону, функцией ОКРУГЛВВЕРХ

Как округлить число в меньшую сторону функцией ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ в Excel делает противоположное тому, что делает ОКРУГЛВВЕРХ, т. е. округляет число вниз.

Синтаксис:Как сделать чтобы excel считал округленные числа?

Число — число, подлежащее округлению.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Работает как аргумент число_разрядов функции ОКРУГЛ, за исключением того, что число всегда округлено в меньшую сторону.

Следующее изображение демонстрирует, как округлить число в Excel в меньшую сторону функцией ОКРУГЛВНИЗ в действии.

Как округлить число в Excel – Примеры формул, как округлить число в меньшую сторону, функцией ОКРУГЛВНИЗ

Так выполняется округление чисел в Excel. Надеюсь, теперь вы знаете, как среди всех этих способов, как округлить число в Excel, выбрать наиболее подходящий для ваших нужд.

Источник: https://naprimerax.org/posts/89/kak-okruglit-chislo-v-excel

Округление чисел в Microsoft Excel

Редактор таблиц Microsoft Excel широко применяется для выполнения разного рода вычислений. В зависимости от того, какая именно задача стоит перед пользователем, меняются как условия выполнения задачи, так и требования к получаемому результату.

Как известно, выполняя расчёты, очень часто в результате получаются дробные, нецелые значения, что в одних случаях хорошо, а в других, наоборот, неудобно. В этой статье подробно рассмотрим, как округлить или убрать округление чисел в Excel. Давайте разбираться.

Поехали!

Как сделать чтобы excel считал округленные числа?

Для удаления дробных значений применяют специальные формулы

О существовании специальной функции округления в Экселе знают далеко не все пользователи. Случается, что некоторые из них ошибочно принимают формат значений, то есть отображаемое количество знаков после запятой, за округление. Далее в статье разберёмся, что к чему и как всё делается.

Для начала отметим, что функция «Формат числа» применяется в случаях, когда вид числа необходимо сделать более удобным для чтения. Кликните правой кнопки мыши и выберите в списке пункт «Формат ячеек». На вкладке «Числовой» установите количество видимых знаков в соответствующем поле.

Как сделать чтобы excel считал округленные числа?

Но в Excel реализована отдельная функция, позволяющая выполнять настоящее округление по математическим правилам. Для этого вам понадобится поработать с полем для формул. Например, вам нужно округлить значение, содержащееся в ячейке с адресом A2 так, чтобы после запятой остался только один знак. В таком случае функция будет иметь такой вид (без кавычек): «=ОКРУГЛ(A2;1)».

Как сделать чтобы excel считал округленные числа?

Принцип прост и понятен. Вместо адреса ячейки вы можете сразу указать само число. Бывают случаи, когда возникает необходимость округлить до тысяч, миллионов и больше. Например, если нужно сделать из 233123 — 233000.

Как же быть в таком случае? Принцип тут такой же, как было описано выше, с той разницей, что цифру, отвечающую за количество разделов, которые необходимо округлить, нужно написать со знаком «-» (минус). Выглядит это так: «=ОКРУГЛ(233123;-3)».

В результате вы получите число 233000.

Как сделать чтобы excel считал округленные числа?

Если требуется округлить число в меньшую либо в большую сторону (без учёта того, к какой стороне ближе), то воспользуйтесь функциями «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».  Вызовите окно «Вставка функции». В пункте «Категория» выберите «Математические» и в списке ниже вы найдёте «ОКРУГЛВНИЗ» и «ОКРУГЛВВЕРХ».

Ещё в Excel реализована очень полезная функция «ОКРУГЛТ». Её идея в том, что она позволяет выполнить округление до требуемого разряда и кратности. Принцип такой же, как и в предыдущих случаях, только вместо количества разделов указывается цифра, на которую будет заканчиваться полученное число.

В последних версиях программы реализованы функции «ОКРВВЕРХ.МАТ» и «ОКРВНИЗ.МАТ». Они могут пригодиться, если нужно принудительно выполнить округление в какую-либо сторону с указанной точностью.

Как сделать чтобы excel считал округленные числа?

Как вариант, решить проблему можно при помощи функции «ЦЕЛОЕ», принцип которой заключается в том, что дробная часть просто отбрасывается, округляя вниз.

Иногда программа автоматически округляет полученные значения. Отключить это не получится, но исправить ситуацию можно при помощи кнопки «Увеличить разрядность». Кликайте по ней, пока значение не приобретёт нужный вам вид.

Как сделать чтобы excel считал округленные числа?

Теперь, когда вы разбираетесь, как выполнять округление числа, вам будет проще выполнять ряд задач в программе. Кроме того, эти навыки помогут вам и в решении повседневных вопросов, связанных с расчётами. Пишите в х были ли статья полезной для вас и продолжайте совершенствовать навыки работы в Microsoft Excel.

Источник: https://nastroyvse.ru/programs/review/okruglenie-chisel-excel.html

Округление в Excel. Пошаговая инструкция

Округление чисел в Excel нужно для удобного форматирования, прогнозирования и коммуникации.

Существует множество способов округления, такие как округление до целого числа, округление в большую сторону, округление в меньшую сторону и т.д. В Excel мы можем округлять числа с помощью функций. Их мы и рассмотрим в этой статье.

Округление чисел в Excel с помощью изменения формата ячейки

Если вы хотите округлить числа исключительно с целью презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  • Кликнуть по ячейке с числовым значением;
  • Открыть меню форматирования ячейки с помощью сочетания клавиш CTRL+1 или кликнуть по ячейке правой кнопкой и в выпадающем списке выбрать пункт “Формат ячеек“;
  • В всплывающем окне “Формат ячеек” перейти на вкладку “Число“;
  • В разделе “Числовые форматы” кликнуть по пункту “Числовой“;
  • В меню окна найти пункт “Число десятичных знаков” и указать точное количество знаков после запятой, которое вы хотите оставить;
  • Кликните по кнопке “ОК” для сохранения настроек форматирования.

Как сделать чтобы excel считал округленные числа?

Важно! Этот метод только визуально округляет число, не “отрезая” числа после запятой.

Округление в Excel с помощью функции ОКРУГЛ

Функция ОКРУГЛ часто используется в Excel для округления чисел. С ее помощью вы можете задать количество чисел после запятой.

Синтаксис

=ОКРУГЛ(число;число_разрядов)

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Основы использования функции

  • если аргумент число_разрядов больше “0”, то число округляется до указанного количества десятичных знаков. Например,  =ОКРУГЛ(500,51;1) вернет “500.5”;
  • если аргумент число_разрядов равен “0”, то число округляется до ближайшего целого числа. Например, =ОКРУГЛ(500,51;0) вернет “501”;
  • если аргумент число_разрядов меньше “0”, то число округляется влево от десятичного значения. Например, =ОКРУГЛ(500,51;-1) вернет “501”.

Функция ОКРУГЛ работает на основе математического правила, по которому она определяет в большую или меньшую сторону следует округлить число:

  • Если число после запятой равно от 0 до 4, то округление будет произведено в меньшую сторону;
  • Если число после запятой равно от 5 до 9, то функция округлит в большую сторону.

На скриншоте ниже показаны примеры использования функции:

Как сделать чтобы excel считал округленные числа?

Округление в Excel в большую сторону с помощью функции ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число в большую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВЕРХ(число;число_разрядов) 

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

Примеры использования функции ниже:

Как сделать чтобы excel считал округленные числа?

Округление в Excel в меньшую сторону с помощью функции ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ округляет число в меньшую сторону, вне зависимости от того, какое число стоит после запятой.

Синтаксис

=ОКРУГЛВВНИЗ(число;число_разрядов) 

Аргументы функции

  • число – числовое значение, которое вы хотите округлить;
  • число_разрядов – значение десятичного разряда, до которого вы хотите округлить первый аргумент функции.

На скриншоте ниже примеры использования функции:

Как сделать чтобы excel считал округленные числа?

Источник: https://excelhack.ru/okruglenie-v-excel/

Округлить до

MulTEx » 13 Январь 2018       Дмитрий       1776 просмотров

Вызов команды:
MulTEx -группа Ячейки/ДиапазоныЯчейкиОкруглить до

Как сделать чтобы excel считал округленные числа?

Округлить значения выделенных ячеек до — указывается количество десятичных разрядов, до которого надо округлить число. Например, если в ячейке записано число 45 127,1384. и указано 2, то число будет округлено до двух знаков после запятой, при этом произойдет округление ровно так же, как это делает Excel: 45 127,14.

Но есть и другие ситуации — когда округлить надо не просто знаки — а целые числа. К примеру, число 45 127,13 необходимо округлить до тысяч, чтобы получить 45 000. Тогда надо будет указать количество знаков после запятой с минусом: -3. Если число надо просто округлить до целого, то необходимо указать количество знаков после запятой — 0.

Диапазон знаков работает от -15 до 15.

Не изменять ячейки с формулами — если установлен, то округление будет производится исключительно для ячеек, не содержащих формулы.

Может пригодиться, если на листе перемешаны ячейки с данными, вводимыми вручную и формулами, которые производят вычисления на основании введенных вручную.

Тогда можно выделить все ячейки, не задумываясь в каких формулы, а в каких нет, установить флажок Не изменять ячейки с формулами и выполнить команду.

Преобразовывать числа, записанные как текст, в числа — по умолчанию команда игнорирует ячейки, в которых записан текст. При этом если в ячейке записано число, но записано как текст, то команда воспримет его как текст и проигнорирует.

Заметка: Что такое число, записанное как текст? Это когда в ячейке отображается число, но по типу данных является текстом. Как правило такие числа помечаются зеленым треугольником в левом верхнем углу ячейки.

Формат отображения для таких чисел невозможно изменить напрямую через Формат ячеек, многие функции не учитывают(например СУММ(SUM)).

Если установить флажок Преобразовывать числа, записанные как текст, в числа, то команда Округлить до сама определит такие числа, преобразует их в реальные числа и округлит. Иначе команда будет игнорировать такие числа, считая их текстом.

Так же надо быть осторожным с датами и временем. Т.к. эти данные являются для Excel числовыми, то они так же будут округлены, что может быть нежелательным. Читать подробнее про то, как Excel воспринимает данные >>

Для чего это вообще может быть нужно?
Часто при выгрузке документов из других систем и файлов(вроде 1С, файлов CSV, текстовых файлов и т.п.) в Excel числа выгружаются с «хвостами» — 5 и более знаков после запятой: 546 932,78923. Но в ячейке они могут отображаться с округлением — 546 932,79.

Как правило это происходит из-за назначенного формата ячеек через Формат ячеекЧислоЧисловойЧисло десятичных знаков=2:
Как сделать чтобы excel считал округленные числа?
Это часто приводит к расхождениям расчетов формулами с расчетами на калькуляторе, т.к. на калькуляторе мы суммируем числа с двумя знаками после запятой, а Excel при суммировании формулами учитывает все 5 знаков, т.е. реальное значение числа.

Часто в таких ситуациях применяют функции вроде ОКРУГЛ(ROUND), но далеко не всегда это удобно и практично, т.к. формула должна быть записана в другие ячейки. А это приводит к дополнительным неудобствам(создание доп.столбцов, дублирование листов, таблиц и т.п.).

С помощью команды Округлить до это можно сделать прямо в этих же ячейках, при этом допускается выделить несколько несмежных ячеек или всю нужную область на листе, вызвать команду и указать нужное количество десятичных разрядов. Так же можно указать, чтобы преобразовывались исключительно ячейки с числами, а ячейки с формулами пропускались. Для этого надо установить флажок Не изменять ячейки с формулами.

Источник: https://www.excel-vba.ru/multex/okruglit-do/

Excel. Формулы. Округление до кратного

При работе с числовыми данными операции округления совсем не редки. Чаще всего мы подразумеваем под ними округление до некоторого числа разрядов (обычно — после запятой). Сюда же можно отнести и округление до десятков, сотен, тысяч и т.д.

Однако, иногда возникает необходимость округлить число с нужной точностью, то есть до ближайшего числа, кратного заданному. Например, 19 округлить с точностью до 5 (результат — 20, ближайшее к 19 число, которое кратно 5).

Для подобного рода округлений в Excel есть встроенная математическая функция ОКРУГЛТ(). Она принимает 2 аргумента:

  • округляемое число (в примере выше — 19);
  • точность округления (в примере выше — 5).

Данная функция производит округление с избытком, то есть делит исходное число на указанную точность, и если остаток от деления больше или равен половине точности, то возвращается первое число, которое больше исходного и кратно заданному. Иначе возвращается первое число, которое меньше исходного и кратно заданному. Пример вычисления — на рисунке ниже.

В качестве точности можно указывать и положительные, и отрицательные числа, и десятичные дроби. Единственное правило — знак исходного числа и числа, указывающего точность, должен быть одинаковым, иначе функция вернет ошибку #!ЧИСЛО.

Несколько примеров вычисления:

Если Вам нужно округлять число с кратностью 10, 100, 1000 и т.д., то можно использовать для этого другую функцию — ОКРУГЛ().

В качестве второго аргумента нужно указать отрицательное число, указывающее на количество разрядов, до которых нужно округлить.

Так, чтобы округлить число 156 до десятков, нужно ввести формулу =ОКРУГЛ(156;-1), а чтобы округлить число 123456 до 1000, ввести =ОКРУГЛ(123456;-3).

Иногда нужно получить на выходе число, оканчивающееся, например, на 99 (как на ценниках в магазинах). В таком случае следует округлить заданное число кратно 100, а затем вычесть единицу. Формула будет выглядеть так: =ОКРУГЛТ(15678;100)-1 или =ОКРУГЛ(15678;-2)-1, а результат будет равен 15699.

Видеоверсию данной статьи смотрите на нашем канале на YouTube

Чтобы не пропустить новые уроки и постоянно повышать свое мастерство владения Excel — подписывайтесь на наш канал в Telegram Excel Everyday

Куча интересного по другим офисным приложениям от Microsoft (Word, Outlook, Power Point, Visio и т.д.) — на нашем канале в Telegram Office Killer

  • Вопросы по Excel можно задать нашему боту обратной связи в Telegram @ExEvFeedbackBot
  • Вопросы по другому ПО (кроме Excel) задавайте второму боту — @KillOfBot
  • По заказам и предложениям обращайтесь к нам на сайте tDots.ru
  • С уважением, команда tDots.ru

Источник: https://zen.yandex.ru/media/id/59affb7afd96b11e8eadd771/5a55c4a148267718467192fe

Округление чисел в Microsoft Excel | @.kak | IT

08.10.2019

Часто при работе с электронными таблицами перед пользователем встаёт необходимость округлить число. Ниже мы рассмотрим различные варианты решения поставленной задачи.

  1. Выделите нужные ячейки;
  2. Кликните правой кнопкой мыши по выделенной ячейке и выберите пункт «Формат ячеек» из контекстного меню;
  3. На вкладке «Число» выберите формат «Числовой»;
  4. В правой части окна установите количество знаков после запятой, поле «Число десятичных знаков», и нажмите на кнопку «Ок».

Именно использование функции позволит решить практически все задачи с округлением числа. Использовать мы будем функцию «ОКРУГЛ».

Формула округления будет иметь следующий вид:

=ОКРУГЛ(число или ячейка с числом;число_разрядов).

Простое округление

Во второй части формулы нужно указать число разрядов. В качестве примера возьмем число 15,185 и укажем 1 разряд =ОКРУГЛ(153,185;1). В результате мы получим округление до 15,2.

Округление до ближайшего целого числа

Если в формуле указать число разрядов 0, то в результате получим округление до ближайшего целого числа. Пример: =ОКРУГЛ(153,185;1) в результате выдаст 153.

Округление в большую или меньшую сторону

Изначально функция ОКРУГЛ работает на основании математического правила:

  • Если после запятой число от 0 до 4, то округление производиться в меньшую сторону;
  • Если же после запятой число от 5 до 9, то округление производиться в большую сторону;

Не всегда это правило позволяет получить нужный результат. Для таких случаев используются функции ОКРУГЛВВЕРХ и ОКРУГЛВНИЗ. Синтаксис не отличается от базовой функции ОКРУГЛ, но в случае с ОКРУГЛВВЕРХ число всегда будет округляться в большую сторону, когда ОКРУГЛВНИЗ округляет в меньшую сторону.

Примеры:

  • =ОКРУГЛВВЕРХ(153,185;0) выдаст число 154;
  • =ОКРУГЛВНИЗ(153,185;0) даст результат 153.

Округление с заданной кратностью

Иногда требуется округлить число с определённой кратностью. Например, нужно округлить 3,785 так, что бы результат был кратен 0,5. Для этого используется функция ОКРУГЛТ. Пример: =ОКРУГЛТ(3,785;0,5) выдаст результат 4.

(1 votes, average: 5,00

Источник: https://akak.pro/windows/tekstovye-redaktory/okruglenie-chisel-v-microsoft-excel/

Ссылка на основную публикацию
Adblock
detector