Как сделать сумму произведений в excel?

В прошлом посте мы рассмотрели подсчет значений в Эксель. А сегодня мы узнаем, как в Excel посчитать сумму значений. Эта задача может поставить в тупик, если структура таблицы сложная, или нужно сделать выборочное суммирование. Дочитайте этот до конца, вас ждёт описание новой уникальной функции с отличным функционалом.

Как считают сумму значений новички? Пишут формулу, где через «+» перечисляют все слагаемые и остаются довольными результатом. Но это работает, если слагаемых 5-10. А как быть, если их больше?

Самый простой способ – выделить мышью все слагаемые и посмотреть результат в строке состояния.

Как сделать сумму произведений в excel?Сумма в строке состояния

Такой способ хорош, если нужно узнать сумму, без использования в других формулах и таблицах. А если результат сложения нужно отобразить на листе – можно пользоваться функциями суммирования.

Функции суммирования в Эксель

Простейшая функция суммирования выглядит так: =СУММ(аргумент1 ; аргумент2;…). Её можно использовать, когда есть перечень ячеек, массив, несколько массивов для сложения. Аргументами могут быть числа, ссылки на ячейки с числами, диапазоны. В следующем примере я просуммировал оклады работников отделов Экономики и Продаж в некой организации:

Как сделать сумму произведений в excel?Функция СУММ

Если нужно посчитать сумму произведений неких чисел, пользуйтесь функцией =СУММПРОИЗВ(массив1; [массив2];…). Функция перемножит соответствующие элементы массивов, а результаты умножения просуммирует. Понятно, что все массивы, заданные в функции, должны иметь одинаковое количество строк и столбцов.

В примере ниже есть оклады работников в у.е. и курсы валюты. Нужно посчитать суммарный оклад всех работников в валюте их страны. Т.е. формула будет иметь вид: =СУММПРОИЗВ(Оклады ; Курсы). Функция умножит каждый оклад на курс и сложит все произведения друг с другом:

Как сделать сумму произведений в excel?Сумма произведений в Эксель

Суммирование с условием в Excel

Часто нужно просуммировать только те значения, которые отвечают какому-то условию. Для этого используем функцию =СУММЕСЛИ(Диапазон, Критерий, [Диапазон суммирования]). Как видим, для нее можно задать 3 аргумента:

  • Диапазон – массив, в котором происходит проверка условия. Это обязательный аргумент;
  • Критерий – условие для отбора значений (обязательный аргумент). Ячейки из «Диапазона» будут проверены на соответствие этому критерию. Если вы ищете равенство какому-то числу – просто запишите это число в качестве аргумента. Остальные критерии заключаются в кавычки. Например:
    • 12 – значение равно двенадцати
    • «>12» — значение больше двенадцати
    • «Обувь» — значение равно «Обувь»
  • Диапазон суммирования – массив значений, которые будут просуммированы. Он должен иметь столько же строк и столбцов, сколько в «Диапазоне». Это необязательный аргумент. Если он не задан, просуммированы будут значения из массива «Диапазон».

В этом примере я сложил оклады всех сотрудников отдела логистики:

Как сделать сумму произведений в excel?Сумма с условием

А что, если нужно задать несколько условий? Эксель прекрасно справится с такой задачей, используем функцию:

 СУММЕСЛИМН(диапазон суммирования ; диапазон условия1; условие1; диапазон условия2 ; условие2 ; …).

Конечно, диапазоны суммирования и условий должны иметь одинаковое количество столбцов и строк, иначе формула выдаст ошибку. В примере я просуммировал зарплату только работников отдела экономики с окладом выше 100 у.е.:

Как сделать сумму произведений в excel?Сумма с несколькими условиями

Мощная и гибкая функция АГРЕГАТ

А теперь представляю вам обещанную новинку. Функция АГРЕГАТ впервые появилась в Excel 2010 и сразу решила многие мои проблемы. Что если нужно посчитать сумму только видимых ячеек? Функция СУММ сложит все ячейки диапазона, даже если они скрыты. Что делать?

А если массив содержит ошибки расчетов, которые нужно игнорировать? Эти и многие другие задачи решает функция: =АГРЕГАТ(номер функции ; параметр ; массив;…). Функция имеет аргументы:

  1. Номер функции – укажите что именно нужно подсчитать. Например, количество значений, сумму, максимум и т.д. При вводе формулы появится подсказка:

Как сделать сумму произведений в excel?Функция Агрегат, первая подсказка

  1. Параметр – даёт возможность выбрать данные, которые функция будет игнорировать. Например, скрытые ячейки, ошибки и др. При вводе так же будет подсказка:

Как сделать сумму произведений в excel?Функция Агрегат, вторая подсказка

  1. Массив – та группа ячеек, для которой производится расчет
  2. Прочие параметры – в зависимости от значения первого аргумента, функция может попросить у вас дополнительные аргументы

Описывать функцию агрегат можно долго, но главное – вовремя узнать о её существовании, и начать свои эксперименты. Она вас не раз удивит и сэкономит множество времени, пользуйтесь!

Прямо сейчас оставлю вас наедине со всеми описанными функциями. Попрактикуйтесь немного, чтобы они остались в вашей памяти.

А следующие посты снова очень важные – это функции поиска и выбора данных. Если вы читаете этот пост – обязательно прочтите и следующий, это будет очень полезно!

Не забыли подписаться на блог? Сделайте это прямо сейчас, чтобы всегда первыми читать новые статьи!

Источник: https://officelegko.com/2016/03/05/summa-v-excel-ot-prostogo-k-effektivnomu/

Как написать формулу в Excel

Редактор таблиц Microsoft Excel имеет очень широкий набор возможностей для решения задач самой разной сложности в различных сферах деятельности. Именно благодаря этому Эксель стал таким популярным среди пользователей по всему миру.

Одним из базовых навыков работы с программой является проведение простейших вычислений и математических операций. В этой статье подробно разберём, как выполнять сложение, вычитание, умножение и деление в Excel.

Давайте же начнём! Поехали!

Как сделать сумму произведений в excel?

Математические операции выполняются без использования калькулятора

Все расчёты в Экселе основаны на построении простых формул, с помощью которых программа и будет производить вычисления. Для начала необходимо создать таблицу со значениями. Обратите внимание на то, что каждая ячейка таблицы имеет свой адрес, который определяется буквой и цифрой. Каждая буква соответствует столбцу, а каждая цифра — строке.

Начнём с самых простых операций — сложения и вычитания. Для сложения чисел можно использовать, так называемую функцию «Автосумма». Ей удобно пользоваться в случаях, когда необходимо посчитать сумму чисел, которые стоят подряд в одной строке, столбце либо в выделенной вами области.

Чтобы воспользоваться этим инструментом, перейдите во вкладку «Формулы». Там вы обнаружите кнопку «Автосумма». Выделив участок таблицы со значениями, которые нужно сложить, кликните по кнопке «Автосумма». После этого появится отдельная ячейка, содержащая результат вычисления.

Это был первый подход.

Как сделать сумму произведений в excel?

Второй подход заключается в том, что формула для расчёта вводится вручную. Допустим, перед вами стоит задача вычислить сумму чисел, разбросанных по таблице. Для этого сделайте активной (кликните по ней левой кнопкой мыши) ячейку, в которую желаете поместить результат вычисления.

Затем поставьте знак «=» и по очереди вводите адрес каждой ячейки, содержимое которой нужно просуммировать, не забывая ставить знак «+» между ними. К примеру, у вас должно получиться: «=A1+B7+C2+B3+E5». После того как будет введён адрес последней ячейки, нажмите на клавиатуре «Enter» и вы получите сумму всех отмеченных чисел. Необязательно вводить каждый адрес вручную.

Достаточно кликнуть по определённой ячейке и в поле для формул сразу отобразится её адрес, ставьте после него «+» и переходите к следующей.

Как сделать сумму произведений в excel?

Существует ещё один подход — использование функции «Специальная вставка». Этот способ удобен тем, что позволяет суммировать данные из нескольких отдельных таблиц, при условии, что все их графы одинаковые. Для начала создайте сводную таблицу, в которую вы будете вставлять скопированные данные.

Выделите числа одной таблицы и вставьте их в сводную, далее поступите так же со значениями второй таблицы, только в этот раз кликните по ячейке правой кнопкой мыши и выберите пункт «Специальная вставка». В открывшемся окне в разделе «Вставить» отметьте «Значения», а в разделе «Операция» выберите сложить.

В результате все данные просуммируются.

Как сделать сумму произведений в excel?

Вычитание в Excel выполняется таким же способом, как и сложение. Вам понадобится ввести формулу, указав необходимые ячейки, только вместо знака «+» между адресами ставится «–».

Чтобы умножить числа в Экселе, напишите формулу, отмечая нужные данные и ставя между ними знак «*». Формула будет иметь следующий вид: «=A3*A7*B2».

Как сделать сумму произведений в excel?

Деление производится аналогичным образом, только используется знак «/». Также вы можете выполнять несколько арифметический операций сразу. Формулы строятся по математическим правилам. Например: «=(B2-B4)*E8/(A1+D1)*D4». Построенная вами формула может быть любой сложности, главное, не забывать основные математические правила, чтобы расчёт был выполнен верно.

Как сделать сумму произведений в excel?

Владея навыками простых арифметических вычислений в программе Microsoft Excel, вы уже сможете упростить себе процесс решения некоторых задач и сэкономить время. Эксель позволяет решать сложные уравнения, выполнять инженерный и статистический анализ.

Постепенно овладевая базовыми функциями и инструментами программы, вы научитесь выполнять всё больше операций в редакторе Excel.

Пишите в х помогла ли вам статья разобраться с возникшими вопросами и делитесь своим опытом с другими пользователями.

Источник: https://nastroyvse.ru/programs/review/prostye-raschyoty-excel.html

Функция СУММПРОИЗВ в Excel

Как сделать сумму произведений в excel?      Добрый день!

     Эту статью я хочу посвятить, не побоюсь этого слова, одной из самых полезных функций для экономистов всех рангов и мастей, это функция СУММПРОИЗВ в Excel. Я кстати при первоначальном знакомстве, совсем ее проигнорировал, не поняв всего волшебства ее возможностей.

Она показалась мне какой-то бесполезной и ненужной, тем более что я мог суммировать элементы массивов я мог и с помощью других функций Excel.

Функция СУММПРОИЗВ в Excel содержит в себе одновременно элементы таких функций как ЕСЛИ, СУММ, СУММЕСЛИ и СУММЕСЛИМН, а также может манипулировать вычислениями в 255 массивах, что согласитесь, отличная возможность.

     Возможности и варианты когда применяется функция СУММПРОИЗВ в Excel большая и позволяет попросту отбросить множество отборочных и промежуточных вычислений.

     Для начала рассмотрим правильный синтаксис, который нужен что бы функция СУММПРОИЗВ в Excel отлично работала:

      = СУММПРОИЗВ(ваш_массив1;[ваш_массив2];[ваш_массив3];…и т.д.), где

  • ваш_массив1 – является обязательным критерием, в нем указываются те компоненты которые необходимо перемножить, а после результаты будут сложены;
  • ваш_массив2, ваш_массив3…. и т.д. – является необязательным критерием, но если количество ваших массивов, которые нужно перемножить и сложить полученные результаты, от 2 до 255 тогда они будут обязательны. Как сделать сумму произведений в excel?

     Ну как вы знаете лучше всего учится на примерах, хоть на своих, хоть на чужих, кроме ошибок. Поэтому давайте рассмотрим, как наша функция СУММПРОИЗВ в Excel работает в условия приближенных к боевым.

Читайте также:  Как сделать очень мелкий шрифт в Word?

     Возьмем таблицу по продажам фруктов и произведем вычисления с помощью функции СУММПРОИЗВ. Как сделать сумму произведений в excel?    Как видно для вычислений нужного нам значения была написана формула: =СУММПРОИЗВ((B2:B11=$H$5)*(D2:D11=$H$6);F2:F11), работу которой рассмотрим поподробнее. Вычисления «B2:B11=$H$5» означают что в массиве данных нужно выбрать всё с критерием «$H$5» или «Яковлев С.И.». Следующим действием «D2:D11=$H$6» мы отбираем в массиве данные со значением «$H$6» или «Яблоко». При совпадении значений в этих диапазонах происходит суммирование в массиве «F2:F11» и мы получаем результат.

     Рекомендую в формулах использовать абсолютные ссылки, когда критериями у вас выступает значение в ячейках, это снизит риск возникновения ошибки в формулах во много раз.

     В этом примере задачку можно решить и другими способами, с помощью других функций или цепочки вычислений, но часто это всё лишнее и намного проще написать формулу один раз и получить нужный результат. Как сделать сумму произведений в excel?     Теперь мы немного усложним наше задание и добавим еще условия в нашу задачку, такие как дата, нам вдруг стало интересно, сколько же яблок продал наш менеджер за последние две недели марта. Этот пример рассмотрим еще и потому что могут быть изменения в критериях товара, сейчас у нас написано «Яблоко», а ведь можно приписать сорт и всё изменится «Яблоко «Голд»» и тогда наша формула не сработает. Как сделать сумму произведений в excel?     Для решения нашей задачи нам нужна формула следующего вида: =СУММПРОИЗВ((B2:B11=$H$5)*(D2:D11=$H$6)*(E2:E11>=$H$9)*(E2:E11=$H$9) и (E2:E11=» (больше и равно) и «

Источник: http://topexcel.ru/funkciya-summproizv-v-excel/

Как вычислить сумму произведений в Excel с помощью встроенной функции?

Как сделать сумму произведений в excel?

Времена, когда бухгалтеры рассчитывали заработную плату при помощи ручных счет или калькулятора с минимальным набором функций и огромными кнопками, канули в небытие. На сегодняшний день все экономические и бухгалтерские расчеты производятся с использованием программных средств, есть множество специализированного программного обеспечения, которое позволяет выполнять работу в автоматическом режиме. Но иногда возникает необходимость выполнить какие-либо вычисления, не предусмотренные программным обеспечением, используемым работодателем. Тогда на помощь приходят всем знакомые средства Microsoft Office.

Microsoft Excel – это один из основных инструментов для работы с цифрами и массивами чисел, для сортировки и выборки записей, анализа данных, составления планов и диаграмм.

В указанном пакете имеется ряд встроенных функций, которые позволяют выполнять вычисления в автоматическом режиме.

Функции позволяют значительно упростить формулы, которые используются в электронной таблице Excel, для того чтобы документ не был перегружен длинными формулами и вычислениями. Ознакомиться с полным перечнем встроенных функций в Excel можно, используя справку Microsoft Office.

Как сделать сумму произведений в excel?

Одна из множества полезных функций, которые помогают работать с многомерными массивами данных и матричным вычислениям в Excel, – сумма произведений.

Как в Excel можно воспользоваться встроенными функциями?

Встроенные функции в Excel расширяют основные возможности системы, и для того, чтобы просмотреть весь перечень указанных возможностей, можно просто воспользоваться значком fx, расположенным перед строкой формул (белая строка, в которой набираются символы при заполнении ячеек в Excel).

Как сделать сумму произведений в excel?

После нажатия значка fx появится окно «Мастера функций». Следуя его подсказкам, можно выбрать подходящую функцию и получить краткую информацию по работе с ней. При этом можно использовать несколько вариантов поиска функции:

  1. Применить фильтр и установить категорию функции для облегчения поиска необходимой формулы, которая позволит сделать необходимые вычисления. Сумма произведений в Excel входит в категорию «Математические».
  2. Использовать поиск по названию (этот вариант подойдет только в том случае, если известно название необходимой функции в Excel). В окне «Поиск функции» необходимо набрать название и нажать кнопку «Поиск», система сама найдет названия встроенных функций, соответствующие введенному запросу. Для того, чтобы вычислить сумму произведений чисел из заданных массивов, в окне поиска следует набрать название функции – «СУММПРОИЗВ».

Для того, чтобы воспользоваться встроенной функцией, необходимо выбрать ее курсором и нажать кнопку ОК в окне «Мастера функций». После выполнения указанных действий появится окно «Аргументы функции», в котором необходимо будет указать все требуемые параметры.

В случае, если название функции заведомо известно, и пользователю не нужны дополнительные подсказки по ее использованию, можно просто поставить в строке формул знак равно (=) и ввести название встроенной функции. При этом необходимо помнить, что помимо названия потребуется ввести еще и аргументы заданной функции Excel.

Аргументы функции для вычисления суммы произведений

Функция для вычисления суммы произведений чисел из заданных массивов определяет итог выполнения определенных действий со значениями, которые используются в качестве аргументов функции.

При этом в качестве аргументов могут выступать значения различных типов, а система подскажет пользователю необходимый.

Формула суммы произведений в Excel перемножает соответствующие значения из указанных массивов (в качестве массивов используются определенные строки или столбцы) и возвращает сумму произведений значений, приведенных в массивах.

Синтаксис функции и разделительные знаки

Для того, чтобы встроенные функции работали корректно, следует четко соблюдать установленный для них синтаксис (то есть использовать стандартные знаки разделения между аргументами функции).

Функция для вычисления суммы произведений имеет следующий синтаксис – «СУММПРОИЗВ(массив1,массив2,массив3,…)».

То есть для корректных вычислений следует применять скобки и запятые, а для указания начальных и конечных ячеек с массивами в качестве разделителя использовать двоеточие (:).

При этом в качестве аргументов могут выступать значения, которые предоставляют информацию для события, действия, метода, свойства, функции или процедуры. Массив 1 является обязательным аргументом для вышеуказанной функции, а последующие массивы задаются, исходя из необходимости.

Количество необязательных массивов (компоненты которых будут перемножаться для дальнейшего суммирования) может составлять от 2 до 255.

Пример применения функции для вычисления суммы произведений

Для наглядности использования функции СУММПРОИЗВ следует рассмотреть следующий пример:

  1. Заполним ячейки в таблице Excel как показано на рисунке, приведенном ниже.
  2. В строке формул запишем «СУММПРОИЗВ(A2:B5;C2:D5)». Для того, чтобы начать вводить в ячейку какую-либо функцию, следует поставить в ней знак равно, а затем записать корректное название встроенной функции и все необходимые аргументы.
  3. Нажмем клавишу ввода (Enter).

Как сделать сумму произведений в excel?

При этом в ячейке, для которой набиралась формула, Excel выведет результат вычислений. В указанном случае это будет число 9290. Система при этом выполнила следующие арифметические операции:

1×100+3×500+5×230+6×250+2×250+4×130+9×400+2×210=9290.

Ошибки при использовании функции

Самыми распространенными ошибками при использовании встроенных в Excel функций являются:

  1. Использование некорректного синтаксиса (лишний пробел между знаками или запятая, поставленная вместо двоеточия, способны привести к ошибкам работе функции).
  2. Аргументы, которые используются в качестве массивов в указанной функции, должны иметь одинаковую размерность. Если не следовать данному совету, то функция будет работать некорректно и возвратит в ячейку значение ошибки (#ЗНАЧ!).
  3. Если в качестве значений в массивах использовать нечисловые элементы, то они воспринимаются функцией СУММПРОИЗВ как нулевые и могут привести к некорректному конечному результату вычислений.

Как сделать сумму произведений в excel?

Не бойтесь использовать возможности Microsoft Excel по максимуму, и тогда он станет вашим надежным помощником в рутинной работе! Многим пользователям кажется, что вычисление суммы произведений в Excel им никогда не понадобится, но когда они начинают использовать возможности программы в своей работе, то этот функционал оказывается довольно полезным.

Источник: https://autogear.ru/article/393/374/kak-vyichislit-summu-proizvedeniy-v-excel-s-pomoschyu-vstroennoy-funktsii/

Как работает умножение чисел и ячеек в программе Excel

Как сделать сумму произведений в excel?

Excel — программа для работы с таблицами, поэтому операции умножения являются базовыми основами работы с ней

Microsoft Excel — это табличный процессор, который обладает достаточно мощным функционалом для работы с электронными таблицами. Среди многочисленных функций в этой программе стоит отметить самую простую — возможность работать с числами.

Табличный процессор может выполнять как простые операции (сложение, умножение), так и более сложные: решение транспортных задач, подбор параметра, поиск оптимального решения и пр.

Для ознакомления с программой на начальном уровне достаточно будет научиться выполнять простые операции вроде умножения чисел.

Как в Экселе умножать числа?

Для начала следует запомнить, что любые вычисления в Экселе называются формулами, и все они всегда начинаются со знака равно.

То есть нужно выбрать любую пустую клеточку и ввести знак равно. Только после этого можно вводить какие-то данные. К примеру, можно написать так: =5*5 (символ звездочки — это знак умножения).

Программа сразу же поймет, что от нее требуется и выдаст результат — 25.

Если выделить поле, где выводится результат, то можно увидеть саму формулу, которая находится в поле формул (она располагается чуть выше, над рабочим листом Excel). Здесь же ее можно и редактировать. Например, можно дописать так: =5*5*10 (после этого результат тут же изменится).

Но такой метод умножения чисел очень простой, к тому же он нерационален. Допустим, что у пользователя есть таблица с 2 колонками и перед ним стоит задача перемножить их.

Можно, конечно, прописывать все вручную, но это займет слишком много времени. А еще и значения могут периодически меняться, и придется постоянно редактировать формулы.

В общем, всего этого можно не делать, поскольку Эксель умеет выполнять операции с цифрами и другим способом. Например, умножая значения в ячейках.

Видео по операциям умножения в Excel

Как умножить ячейки в Excel?

Для начала нужно заполнить 2 любых поля данными. Например, в поле A1 можно ввести цифру 10, а в поле B1 — 5. После этого надо выполнить следующие действия:

  • выделить поле C1 и ввести знак равенства;
  • щелкнуть левой кнопкой мыши на ячейке A1 и написать звездочку;
  • щелкнуть мышкой на ячейке B1 и нажать Enter.

Два примера формул, при помощи которых можно перемножить значения двух ячеек Excel

После этого в клеточке C1 будет отображено число 50. Если щелкнуть на ячейке C1 и посмотреть на строку формул, то можно увидеть следующее: =A1*B1. Это означает, что теперь Excel умножает не конкретные цифры, а значения в этих полях.

Читайте также:  Как сделать игру через powerpoint?

Если их изменить, результат тоже изменится. Например, в поле A1 можно написать цифру 3, и в поле C1 тут же отобразится результат — 15. Такой способ умножения чисел является классическим.

Как правило, вручную цифры никто не прописывает, всегда умножают ячейки

Есть еще одна небольшая хитрость — копирование формул. В качестве примера можно взять небольшую таблицу (5 строк и 2 столбца). Цель — перемножить значения в каждой строке (т.е. A1 умножить на B1, A2 на B2, …, A5 на B5).

Для того чтобы не писать одну и ту же формулу каждый раз, достаточно написать ее только для первой строки, а затем выделить клеточку с результатом (С1) и потянуть вниз за маленький черный квадратик, который находится в правом нижнем углу.

Формула «потянется» вниз, и результат будет посчитан для всех строк.

Вот таким несложным способом можно умножить в Excel и цифры, и ячейки. Кроме того, этот же принцип действует и для остальных математических операторов (сложение, вычитание, деление). В таких ситуациях нужно всего лишь указать другой арифметический знак, а все операции с цифрами (или полями) осуществляются точно так же.

Источник: https://itguides.ru/soft/excel/umnozhenie-v-excel.html

Как умножать в экселе

Операция умножения – одна из нескольких наиболее используемых в любой сфере деятельности, а табличный редактор Excel – один из наиболее часто применяемых инструментов вычисления в таблицах.

Для понимания всего процесса достаточно рассмотретьпоследовательность действий при умножении двух или нескольких значений в редакторе Excel. Как сделать сумму произведений в excel?

  • Табличный редактор Excel 2007

Если требуется разовое действие — перемножить два числа – то последовательность действий должна быть такой:- перейдите в пустую ячейку таблицы Excel (можно с помощью навигационных клавиш-стрелок, а можно щелкнув нужную ячейку мышью);

— нажмите клавишу «=». Excel интерпретирует это действие как начало ввода формулы;

— теперь печатайте нужное вам математическое действие, используя в качестве знака умножения звездочку (*). Знаки математических действий принято назвать «операторами».

Например, если надо перемножить 2 на 3, то в ячейке вам нужно напечатать «=2*3» — здесь знак равенства остался от предыдущего шага, повторно печатать его не нужно.

Если требуется перемножить не два, а больше чисел — ничего не меняется в правилах, печатайте больше. Например, =2*3*4*7*12;

— по завершению ввода нажмите Enter. Excel рассчитает результат и покажет его в этой же ячейке.

Вместо обычной записи математического действия с использованием оператора умножения (*), можно использовать функцию с именем ПРОИЗВЕД. В этом случае содержимое ячейки таблицы, осуществляющей перемножение пяти чисел, будет выглядеть так: =ПРОИЗВЕД(2;3;4;7;12).

Если надо организовать постоянную форму из нескольких ячеек, чтобы в одной из них напечатать множимое, в другой — множитель, а в третьей увидеть результат умножения:- в первой свободной ячейке напечатайте число (множимое) и нажмите Enter;- во второй свободной ячейке напечатайте второе число (множитель) и нажмите Enter;- в третьей ячейке нажмите клавишу «=» и с помощью клавиш навигации (стрелок) переместитесь в первую ячейку (содержащую множимое). Можно вместо клавиш просто щелкнуть ячейку курсором мыши. Сделав это, нажмите звездочку (оператор умножения). При этом курсор вернется обратно в третью ячейку, а вам нужно с помощью тех же клавиш навигации или курсора мыши перейти во вторую ячейку, содержащую множитель. После этого содержимое ячейки с формулой должно выглядеть, например, так: =A1*A2. Сделав все это, нажмите Enter для завершения ввода формулы и в третьей ячейке увидите результат умножения.Вы построили мини-калькулятор — теперь можете менять числа множимого и множителя, а Excel будет в третьей ячейке показывать их произведение.

И здесь умножаемых чисел не обязательно должно быть только два, действуя точно так же можно организовать нужное вам количество перемножаемых ячеек с числами. Но в этом случае удобнее будет пользоваться не оператором *, а функцией ПРОИЗВЕД.

Тогда вам не надо будет указывать каждую ячейку с числом по отдельности, а можно указать целый диапазон ячеек. Например, если вы поместили перемножаемые числа в ячейки начиная с A1 и заканчивая A8, то содержимое ячейки, показывающей результат перемножения их всех, должно быть таким: =ПРОИЗВЕД(A1:A8).

Диапазон ячеек можно вписать в функцию «вручную», а можно выделить мышью и Excel впишет нужные значения сам.

Если надо разово умножить значение каждой ячейки в столбце (или строке) таблицы на какой-то коэффициент:- в пустой ячейке напечатайте это число-коэффициент;- затем выделите эту ячейку, на вкладке «Главная» в самой первой группе («Буфер обмена») нажмите кнопку «Копировать»;- теперь выделите диапазон ячеек, которые требуется умножить на коэффициент. Это можно сделать как мышкой, так и с помощью стрелок при нажатой клавише CTRL;- в той же группе «Буфер обмена», ниже команды «Вставить», есть стрелка, которая открывает дополнительные варианты вставки — щелкните ее и выберите в списке пункт «Специальная вставка»;- в группе переключателей «Операция» выберите «Умножить»;

— нажмите кнопку «ОК» и Excel перемножит каждую выделенную ячейку на значение коэффициента, скопированного вами в буфер обмена.

Умножение. В отличии от знаков сложения (+) и вычитания (-) клавиши со знаком умножения на клавиатуре нет. Практически во всех языках программирования для знака умножения используется звездочка (*).  Деление. Знака деления на клавиатуре также нет. Знак двоеточия (:) использовать нельзя. Было принято решение использовать для деления слэш (/). Для некоторых символов (к сожалению не для всех) есть возможность набора сочетанием горячих клавиш, например для знака § это будет сочетание Alt+0167: Только цифры нужно набирать на цифровой клавиатуре и после отжатия клавиши Alt нужный символ отображается в любой программе или браузере.  Alt+0215 × знак умножения ( у меня работает при английской раскладке клавы).

  • как в эксель умножение
  • Умножение чисел в Excel
  • Войти на сайт
  • или

Источник: https://www.kakprosto.ru/kak-17832-kak-umnozhat-v-eksele

Формулы массива в Excel — введение

Как сделать сумму произведений в excel?Сегодня я решил приступить к теме, которая будет совсем не для новичков, а именно к формулам массива. Знание формул массива и свободное оперирование ими является одним из признаков значительного уровня в Excel. Формулы массива свободно используются знатоками Excel, на форумах часто можно заметить, как мастера перед аудиторией щеголяют своим уровнем владения этим инструментом.

Многие, точнее подавляющее большинство пользователей, среди которых есть и многолетние практики, вполне спокойно обходятся без формул массива. Причина в том, что это довольно сложный инструмент для понимания, плюс он используется как правило для решения сложных и заковыристых задач. Есть задачи, которые без формул массива (далее ФМ) в принципе средствами Excel не решаемы.

В чем же фишка? Уже из названия видно, что это формулы, которые работают с целыми диапазонами (то бишь массивами). Есть функции, которые работают даже с двумерными массивами, например ИНДЕКС. Но принцип действия гораздо проще, чем в ФМ.

  1. Они позволяют решать сложные задачи там, где пасуют остальные средства Excel, кроме, пожалуй сводных таблиц. Несложные задачи лучше не решать, это как забивать кувалдой кнопку в доску, чтобы повесить объявление о субботнике (был недавно на работе ). Дело даже не в этом, а в том, что они жрут памяти больше обычных формул.
  2. Они позволяют обходиться одной формулой там, где в противном случае надо было бы делать макросы, плодить вспомогательные таблицы и т.д.

Давайте наконец перейдем от вступления к практике. Итак, сначала определимся с массивами. Массив, если по простому, это набор данных, который Excel’ем обрабатывается как один аргумент (параметр). Он может быть одномерным (горизонтальным или вертикальным) или двумерным.

Грубо говоря, наши формулы массива – это те же формулы, что мы используем повседневно, только в качестве аргументов там, где обычная функция использует отдельное значение, формула массива может использовать диапазон.

Первый пример, пока простенький.

У нас есть два диапазона. Мы хотим получить сумму их произведений. Это простой пример, который я обычно реализую следующим образом: добавляю третий столбец (или строчку), получаю произведения и суммирую весь столбец

Сделаем это через формулу массива: сначала мы определяем конечную функцию, это сумма.

=СУММ()

Затем определяем аргументы – а это для нас сумма массива, который сам по себе  является произведением двух массивов, т.е.

=СУММ(массив1*массив2)

И последний, завершающий штрих, без которого Excel огрызнется «сам дурак!» — надо нажать в режиме редактирования CTRL+Shift+Enter.

Есть нюанс – вообще-то есть функция СУММПРОИЗВ, которая призвана давать сумму произведений массивов. Так что прежде чем использовать ФМ, надо посмотреть, может нам помогут функции СУММЕСЛИ и ей подобные?

Пример второй, сложноватый.

Найти сумму 5го, 6го и 7го наибольших элементов набора данных. Как это делается без ФМ: таблица сортируется по убыванию, берется дополнительный столбец, там проставляются порядковые номера и через функцию СУММЕСЛИ вытаскиваем сумму. Ну или еще каким-нибудь способом, которым это можно сделать. Не сильно проще.

Формула массива делает все без дополнительных телодвижений:

=СУММ(НАИБОЛЬШИЙ(B3:B25;{5;6;7}))

Понятно? Нет? Ну, давайте по шагам:

  1. Функция НАИБОЛЬШИЙ ищет те элементы, которые заданы (5,6 и 7-й) по порядку убывания. Результатом будет три числа, т.е. отдельный массив.
  2. Функция СУММ суммирует этот массив.
  • Не буду говорить за всех, я чаще всего использую в ФМ следующие функции:
  • ЕСЛИ
  • ИНДЕКС
  • ПОИСКПОЗ
  • СТРОКА (СТОЛБЕЦ)
  • НАИБОЛЬШИЙ (НАИМЕНЬШИЙ)
  • СУММ
  • И(ИЛИ)
  1. Для нахождения в какой-либо таблице ВСЕХ(!) элементов, отвечающих заданному условию.

Кто уже просматривал мой «Ускоренный практикум», помнит, что с помощью ФМ я выстраивал первую пятерку игроков, ранжируя по определенному признаку. Т.е., у меня например есть таблица банков, где один из признаков – количество банкоматов.

В принципе, самое простое решение – использовать функцию НАИБОЛЬШИЙ, чтобы вытащить первую пятерку (десятку, двадцатку) значений по показателю банкоматов и затем с помощью функции ВПР найти соответствующие им названия банков.

Но что делать, если значения повторяются? (Забудем на время про сводную таблицу.) Т.е., Альфабанк (не путать с реальным названием ) имеет одно и то же количество банкоматов, что и Бетабанк. ВПР в этом случае найдет только первого, того, кто в таблице стоит повыше. Т.е. будет в пятерке банков два Альфабанка.

  1. Для автоматической сортировки и фильтрации элементов.
Читайте также:  Как сделать отточие в Word?

Для решения такой же задачи стандартными средствами потребовалось бы все время пользоваться сортировкой или сводной таблицей. И в этом случае ссылаться на эту таблицу было бы не то что сложно, но немного муторно.

А у меня например, есть в списке тех отчетов, что я составляю, рейтинг банков. Он составляется на ежемесячной основе и содержит 10-20 показателей – кредитный портфель, депозитный портфель, ROE, ROA и т.д.

И по форме отчета есть 10-20 таблиц, которые являются основой для диаграмм, соответственно должны быть отсортированы по убыванию.

Само собой, мне, как и каждому экселисту, лень было делать эти сортировки, поэтому я просто настроил ФМ и теперь просто завожу данные, а они уже сами сортируются и выделяются нужными цветами.

Тонкости использования ФМ:

  1. Бывает, приходится использовать константы, типа {1;2;3;4;5}. Это проще, чем где-то его набивать и вставлять ссылку. Но надо учитывать, что если числа разделяются точкой с запятой, то это горизонтальный массив. А если двоеточием – {1:2:3:4:5} – то вертикальный.
  2. ФМ может быть применена как к ячейке, так и к диапазону. Соответственно, на выходе будет диапазон. Менять формулу в этом случае можно только во всем диапазоне. Как вводится и меняется формула – выделяется диапазон, и забивается формула, завершается CTRL+Shift+Enter.
  3. Отличительным признаком ФМ являются фигурные скобки. Они видны, пока не перейдете в режим редактирования ячейки. Как-то непривычно порой разбирая формулы, видеть, что там где должна быть ссылка на ячейку, стоит диапазон – ЕСЛИ(А1:А5>0;1;0). Меня это сильно удивляло, как так .

Кто еще считает, что можно нормально обойтись и без ФМ, напишите в х к статье, сможете ли реализовать расчет цены остатков на складе по методу ФИФО/ЛИФО.

Эксель Практик
«Глаза боятся, а руки делают»

P.S.

Источник: http://excelpractic.ru/formuly-massiva-v-excel.html

Сумма произведений в Excel

В Microsoft Excel можно проводить разные расчеты, от самых элементарных до более сложных, где задаются определенные условия. Вот и задачу, которую мы с Вами сейчас рассмотрим можно решить по-разному.

В этой статье я покажу, как рассчитать сумму произведений в Excel различными способами: используя привычные «+» и «*», ссылаясь на определенные ячейки или с помощью функции СУММПРОИЗВ.

Возьмем следующий пример: умножим пары чисел, а затем просуммируем их самым простым способом.

Поставьте в ячейку «=» и начните вписывать значения, расставляя между числами знаки суммы и умножения. Эксель посчитает по законам математики – сначала умножит, а потом прибавит. Чтобы получить результат, жмите «Enter».

Если у Вас все значения были записаны как и в примере в А1, то можно не переписывать, достаточно выделить ячейку и поставить в строке формул знак равенства в самом начале.

Еще один вариант – это ссылаться на определенные ячейки, которые берутся для расчета. Преимущества такого способа в том, что если у Вас поменяются значения, например, в заполненной таблице, то сумму произведений не придется исправлять вручную, меняя там числа, все произойдет автоматически.

Для этого поставьте знак равно и выделяйте мышкой ячейки, расставляя между их адресами «+» или «*». Потом нажмите «Enter».

Теперь если я изменю в С1 число 24 на 3, результат в D6 будет пересчитан.

Для расчета суммы произведений в Эксель так же есть специальная формула – СУММПРОИЗВ. Ее использование перед предыдущими способами очевидны: автоматический расчет значений при их изменении, возможность задавать определенные условия, работа с большими массивами.

Примеры СУММПРОИЗВ в Excel, я приводила в отдельной статье, там же и рассказывала, как ей пользоваться.

Давайте возьмем такую таблицу. Посчитаем, сколько заработали, умножив количество проданных фруктов на цену реализации за килограмм. Для этого нужно записать формулу такого вида, указав в качестве аргументов нужные диапазоны со значениями:

=СУММПРОИЗВ(E4:E10;G4:G10)

Если у Вас таблица с большим количеством строк, то можно сделать и по-другому. В качестве аргументов для функции указывайте все столбцы полностью: (E:E;G:G). Теперь перемножаются 10 и 216, 5 и 114, 8 и 96 и так далее.

В аргументах к СУММПРОИЗВ можно задавать определенные условия. Например, чтобы посчитать, сколько мы заработали на яблоках, привезенных именно с Греции, нужна вот такая формула:
=СУММПРОИЗВ((В:В=»Яблоко»)*(С:С=»Греция»);Е:Е;G:G)

Для того чтобы растянуть формулу СУММПРОИЗВ потяните за привычный правый нижний угол ячейки. После этого обязательно нужно посмотреть, какие диапазоны используются в аргументах.

Поскольку я растянула только на одну ячейку, то и столбцы сместились на это же количество, и теперь в формуле перемножаются F и H. Учитывая, что все строки в столбце H пусты, результат получился нулевой.

Представьте, что нам нужно перемножить и просуммировать E с G и F с G. Поэтому в J4 исправляем аргумент H на G.

Если Вы растянули формулу не на одну, а скажем 10 ячеек, то исправлять не совсем удобно. Поэтому лучше закрепить тот столбец, который используется в расчете постоянно.

В примере это G и на него нужно сделать абсолютную ссылку. В первой ячейке с расчетами, у меня это I4, ставим перед G знак «$», чтобы получилось $G4:$G10. Теперь растягивайте.

Из примера видно, что в аргументах столбец E сменился на F, а вот G так и остался.

Используйте любой из способов, и у Вас точно получится рассчитать сумму произведений в Эксель.

Загрузка…

Источник: http://comp-profi.com/summa-proizvedenij-v-excel/

Функция СУММПРОИЗВ() — Сложение и подсчет с множественными условиями в MS EXCEL

Функция СУММПРОИЗВ(), английская версия SUMPRODUCT(), не так проста, как кажется с первого взгляда: помимо собственно нахождения суммы произведений, эта функция может использоваться для подсчета и суммирования значений на основе критериев, а также, в некоторых случаях, избавить от необходимости применений формул массива.

Существует несколько вариантов применения функции СУММПРОИЗВ():

  • нахождение суммы произведений элементов списка (массива);
  • суммирование и подсчет значений, удовлетворяющих определенным критериям;
  • замена формул массива (в некоторых случаях).

Нахождение суммы произведений элементов массивов

В этом разделе показан синтаксис функции СУММПРОИЗВ()и раскрыт ее потенциал для других применений.

Пусть имеется 2 диапазона чисел A3:A6 и B3:B6, содержащие соответственно 2 массива чисел: {4:8:6:1} и {7:6:7:5}. Записав формулу =СУММПРОИЗВ(A3:A6;B3:B6), получим 123.

Результат получен поэлементным перемножением всех элементов двух массивов, а затем сложением полученных произведений.

То есть были выполнены следующие арифметические действия: 4*7 + 8*6 + 6*7 + 1*5= 123

Таким образом, можно найти сумму произведений 3-х, 4-х и т.д. массивов.

Аргументы, которые являются массивами, должны иметь одинаковые размерности (в нашем случае это массивы по 4 элемента). В противном случае функция СУММПРОИЗВ() возвращает значение ошибки #ЗНАЧ!.

В формуле =СУММПРОИЗВ(A3:A6;B3:B6) функция СУММПРОИЗВ() трактует нечисловые элементы массивов как нулевые. Однако, как показано ниже, функцию можно использовать для подсчета текстовых значений.

Что произойдет если указать только 1 массив, т.е.=СУММПРОИЗВ(A3:A6)? Тогда функция СУММПРОИЗВ() вернет сумму элементов, т.е. будет эквивалентна функции СУММ(): =СУММ(A3:A6).

Синтаксис функции СУММПРОИЗВ() позволяет не просто указывать в качестве аргумента определенный диапазон, но и осуществлять арифметические действия перед операцией суммирования. Например, записав:

  • =СУММПРОИЗВ(A3:A6*2), получим сумму произведений =38 (каждый элемент массива из A3:A6 был умножен на 2, затем все произведения просуммированы);
  • =СУММПРОИЗВ(A3:A6*B3:B6), получим результат суммы произведений – 123 (все элементы массивов были попарно перемножены, а затем сложены, т.е. A3*B3+ A4*B4+ A5*B5+ A6*B6), т.е. эта запись эквивалента формула =СУММПРОИЗВ(A3:A6;B3:B6);
  • =СУММПРОИЗВ(A3:A6+B3:B6), получим сумму элементов из двух диапазонов;
  • =СУММПРОИЗВ(A3:A6/B3:B6), получим сумму попарных отношений всех элементов,  т.е. 4/7 + 8/6 + 6/7 + 1/5= 2,9619

Аналогичные вычисления можно выполнить и с функцией СУММ(), только для этого нужно ее ввести как формулу массива, т.е. после ввода функции в ячейку вместо ENTER нажать CTRL+SHIFT+ENTER: =СУММ(A3:A6/B3:B6)

Прелесть функции СУММПРОИЗВ() в том, что после ввода функции в ячейку можно просто нажать ENTER, что снимает некий психологический барьер перед использованием формул массива.

Оказывается, что в качестве аргумента этой функции можно указать не только произведение массивов (A3:A6*B3:B6), но и использовать другие функции и даже применить к массивам операции сравнения, т.е. использовать ее для сложения чисел, удовлетворяющих определенным условиям.

Суммирование и подсчет значений удовлетворяющих определенным критериям

Попробуем подсчитать число значений больших 2 в диапазоне A3:A6, содержащий значения 4, 8, 6, 1.

Если мы запишем формулу =СУММПРОИЗВ(A3:A6>2), то получим результат 0.

Выделив в Строке формул A3:A6>2 и нажав клавишу F9, получим массив {ИСТИНА: ИСТИНА: ИСТИНА: ЛОЖЬ}, который говорит, что мы движемся в правильном направлении: в диапазоне A3:A6 больше 2 только первые 3 значения.

Хотя значению ИСТИНА соответствует 1, а ЛОЖЬ – 0, мы не получим 3, т.к. для перевода значений ИСТИНА/ЛОЖЬ в числовую форму требуется применить к ним арифметическую операцию. Для этого можно, например, применить операцию двойного отрицания (—), что позволит привести массив в числовую форму {1:1:1:0}.

  • Итак, задача подсчета значений больше 2 решается следующим образом: =СУММПРОИЗВ(—(A3:A6>2))
  • Вместо двойного отрицания можно использовать другие формулы: =СУММПРОИЗВ(1*(A3:A6>2)) или =СУММПРОИЗВ(0+(A3:A6>2)) или даже так  =СУММПРОИЗВ((A3:A6>2)^1).
  • Запись >2 является критерием, причем можно указать любые операции сравнения (G8)) – ячейка G8 должна содержать число 2.

Критерии можно применять и к текстовым значениям, например, =СУММПРОИЗВ(—(B3:B6=»яблоки»)) – вернет количество ячеек, содержащие слово яблоки (подробнее, например, в статье Подсчет значений с множественными критериями (Часть 1. Условие И)).

Функцию СУММПРОИЗВ() можно использовать для отбора значений по нескольким критериям (с множественными условиями). Как известно, 2 критерия могут образовывать разные условия:

  • Условие ИЛИ. Например, подсчитать ячеек содержащих значение яблоки ИЛИ груши =СУММПРОИЗВ((B3:B6=»яблоки»)+(B3:B6=»груши»));
  • Условие И. Например, подсчитать количество значений больше 2 и меньше 5: =СУММПРОИЗВ((A3:A6>2)*(A3:A62)*(A3:A6

Источник: https://excel2.ru/articles/funkciya-summproizv-slozhenie-i-podschet-s-mnozhestvennymi-usloviyami-v-ms-excel-summproizv

Ссылка на основную публикацию
Adblock
detector